10

Since I'm on Monterrey (from Mojave), there is syspolicyd process ALWAYS using 35-45% on the CPU!

If I leave the laptop in idle, syspolicyd (Apple Gatekeeper) consumes an average of 37% of the processor; NON-STOP.

This sometimes heats up and the fan to spin. But the main problem is that this drains the battery of the laptop!
I already have virtual machines or Docker or Kubernetes already sucking out all the power.
With this update and the arrival of syspolicyd I practically cannot use my laptop as a mobile device! The battery will be drained.

What I tried:

How do I prevent it from continuously hogging the CPU?
How do I eventually disable the service alltogether?

7
  • I already checked them & tried all the solutions there, thanks. Neither of those questions provide a working solution to the problem. Commented Dec 7, 2021 at 12:59
  • It's always best to document what you have researched & tried already - it saves duplicated effort.
    – Tetsujin
    Commented Dec 7, 2021 at 13:05
  • @Kamafeather How long has this problem been going on for? - Is it a few hours, or weeks and months? - Does htis problem occur if you create a new user account and login as that user only?
    – jksoegaard
    Commented Dec 7, 2021 at 23:21
  • 1
    My 2020 Intel Air has this exact problem. Monterey, syspolicyd dominates all other processes, even after a fresh restart with no opened applications. As i write this, syspolicyd is the top of Activity Monitor if i order by either CPU or CPU Time. I should add, i have tried renice, nice, disabling gatekeeper entirely, manually allowed Dev and Full Disc Access to common apps, etc. Nothing i have tried seems to have a measurable impact.
    – Ben Roux
    Commented Dec 8, 2021 at 20:47

1 Answer 1

6

I figured it out!

Solution

check in the macOS Console.app, filtering by syspolicyd.
There will be lines that are marked with a yellow dot 🟡.

Find those where is reported something like:

Kernel Extension BLOCKED "com.malwarebytes.mbam.rtprotection"

or

Kernel Extension BLOCKED "org.pqrs.driver.Karabiner.VirtualHIDDevice.v061000"

  • In my case I've then found out that Malwarebytes' Kext was deprecated. Reinstalling fixed the extension.

  • With Karabiner, the re-install triggered again the request to enable the extension in System Preferences.
    It finally asks to Allow the extension in "Preferences"->"Privacy & Security" ‼️

So, instead of cleaning manually, just download and re-install the most recent version of the software providing the extension, and suddenly syspolicyd will drop to zero % CPU usage‼️


Rationale

Apparently the issue is with extensions not being Allowed. Even though I am sure I've checked several times in Privacy&Security, there was no sign of any requested extension (so the OS fails to keep a memory record about that required permission).

This was leading the system to waste CPU cycles trying to load an unprivileged extensions and fail, cutting 1/3 of performance and battery life away.

This is a bug in the OS 😑 but hopefully this fix will finally improve a lot of users that were left grudging without a clue and a down-performing "upgraded" system.

🎉

9
  • Where exactly in the Console.app should I look? (which of the tabs in the sidebar) Commented Aug 23, 2022 at 17:44
  • Oh and what permission did Karabiner exactly need in your case? Maybe I can check and manually add it, I might face the same issue Commented Aug 23, 2022 at 17:45
  • Did you try to COMMAND+SPACE and type "Console"? Or looking into the Applications folder? Commented Aug 23, 2022 at 19:45
  • 1
    About Karabiner, the best way I found to retrigger the extension message is to uninstall and reinstall the app. This seems to be a standard procedure that worked and allowed me to fix with all the other apps that also have an extension. Commented Aug 23, 2022 at 19:46
  • 1
    I don't know the exact one, I filter through the main list (Devices->MacBook); or you might try System.log, honestly I can't remember but I don't think I ever had to choose a section: I simply Start Streaming the system events and then look through them, helping myself with the Search box or looking for the yellow circle mentioned in the answer. Sorry if I can't help you better. Commented Aug 26, 2022 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .