I use Quick Look regularly to quickly view the content of files. Sometime recently the behaviour of the feature on my machine (Mac mini 2018, Big Sur 11.3.1) has changed such that it now only displays a small thumbnail of the images, like this:

enter image description here

This only seems to effect files I haven't opened - once a file has been opened (eg. in Preview) Quick Look correctly shows a full screen version of the file.

I've tried restarting and clearing the thumbnail cache (qlmanage -r cache) but to no effect. I've also tried forcing Quick Look to preview a dir of images (ie. qlmanage -p ./*) which works but is very slow when switching images. Once images have been previewed in this way, Quick Look again functions as usual.

What am I missing?

2 Answers 2


This just happened to me (Monterey 12.4, 16" M1 2021 MBP) and I too, tried resetting the Quick Look mechanism (qlmanage -r, qlmanage -r cache) to no avail.

Quitting and restarting Finder fixed it, though

killall Finder

Gaah.. I wrote up this whole question before figuring it out. Hopefully this helps some other unlucky users.

The problem was Dropbox "Smart Sync". The images causing problems were recently "sync'ed" to my machine from Dropbox. Unfortunately, the way Dropbox works these days is to create, sort of, place holder files that are downloaded behind the scenes when first accessed. This explains why Quick Look was unable to show a full screen preview of the images unless they'd been opened first, as opening the files causes them to be (actually) downloaded.

The solution is to right click on the offending files and the Smart Sync > Local option. Although I have all the "Smart Sync" options turned off in my Dropbox prefs, files selectively synced to a machine still enter this state. Apparently the only way to completely disable it is to disable the filesystem integration, but I suspect that would have other consequences.

  • 1
    This also happens with content synced with your iCloud Drive.
    – ErniePC12
    Commented Dec 6, 2021 at 12:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .