I have my Late 2015 iMac running on El Capitan. I tried to upgrade it to Big Sur but the update went in a loop, restarting over and over with the Apple logo and the progress bar. Turning off-on did not help. With difficulties, I had to erase the HHD and reinstall El Capitan.

I tried the above one more time, and then two times trying to install Monterey for the same outcome. Then I tried (twice) to install Monterey from a bootable installer. On both occasions, about half way, the screen went black and the computer restarted.

I cannot understand what's wrong. It also puzzles me that Disk Utility shows that the Mac (which is supposedly standard) has both Fusion HDD 2Tb and a 128GB SSD on board. How can this be?

Lastly, this iMac malfunctioned two months ago. It ceased to boot and there was some strange error -- Disk Utility did not see the HDD until I restarted the Mac for a few times. Only the SSD was visible. However, I managed to recover most of the files from Terminal and reinstall the OS. Disk Utility never showed any disk errors since than.

Any ideas how to update the macOS please?


  1. I was able to update to High Sierra.
  2. Here is what diskutil Terminal command and Disk Utility show (I am confused why these are different). enter image description here


You must log in to answer this question.

Browse other questions tagged .