1

I have an iPhone 13, running iOS 15.1, and I'm not being alerted to push notifications that arrive while the device is asleep.

When I tap the screen, the display lights up and the message preview is there, so I know it's receiving them, but it's not notifying me.

If the phone is awake, and at the Home screen, and a push notification arrives, the phone makes the notification sound and shows the notification as expected.

This is a problem because it applies to text message notifications; I'm missing texts because the phone isn't notifying me. It also applies to notifications from apps.

This is new to iOS 15.

Things I've checked:

  • The physical switch that turns on "Silent Mode" is Off.
  • In Settings/Notifications, "Scheduled Summary" is Off
  • In Messages settings, "Allow Notifications" is On and Sound is set to "Note".
  • In "Sounds & Haptics", the "Ringer and Alerts" volume is about halfway up, and plenty loud when I test it by tapping the drag handle.
  • No "Focus" is on.
  • No Sleep Schedule is configured in the Health app.
  • "Allow Notifications" is On for the specific apps I'm testing with, and the "Sounds" switch is On.

I can't see any reason the phone is delivering notifications silently when the screen is locked; please let me know what else I can try.

3
  • Do you have an Apple Watch by any chance?
    – njboot
    Nov 26, 2021 at 20:53
  • I do .. the watch produces a haptic when I get a notification.
    – stevex
    Nov 27, 2021 at 12:18
  • that’s your issue. I’ll post a response in the main
    – njboot
    Nov 27, 2021 at 16:08

1 Answer 1

1

This is expected behavior due to you having notifications enabled on your Apple Watch:

https://support.apple.com/en-us/HT204791

If your iPhone is locked or asleep and your Apple Watch is unlocked (regardless of whether the watch display is asleep or awake) and on your wrist, you will receive notification alerts and sounds on your watch.

This is so you aren’t receiving duplicate notifications on both devices

If you turn off Wrist Detection (on your iPhone, in the Watch app, go to: My Watch > Passcode – turn off Wrist Detection), then all notifications and the notification sound will be delivered to both devices

Other options would just be enabling the “Do Not Disturb” option on your Apple Watch, or selectively turning off notifications on your watch you only want on Phone.

1
  • This was it for me, and I'm not happy about it. If I enable "Do Not Disturb" on the watch that enables it everywhere, so I don't get any notifications. My watch was in silent mode, which is why I was just getting the haptic, so I turned that off and I get them now, but silent mode gets turned on accidentally sometimes, and when that happens, I'll get no notifications until I notice. But this did solve the mystery, thanks!
    – stevex
    Nov 28, 2021 at 4:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .