0

TextEdit freezes every time while trying to open a file from the menu File->Open (or CMD + O) or via menu File->Recent files. But if I open a file from the Finder (by simply clicking on it) TextEdit opens it correctly without any fail.

I am having this problem on MBP 2019 driven by Monterey Mac OS.

Here is a few crash reports (due to their length do not fit 30k symbols they are on external links):

  1. http://d2.webdemosites.top/textedit-crash-report.txt

  2. http://d2.webdemosites.top/textedit-crash-report-2.txt

Thank you in advance for your help!

2 Answers 2

1

The answer below has no effect.

I tried on an Intel Mac running Monterey 12.0.1 and easily reproduced the bug.

On M1 Mac, still on Monterey 12.0.1 there are no bugs of this type, TextEdit works perfectly.

You can try this :
1) you close Textedit
2) you open the Finder, click inside to get focus, then you do cmd+shift+g 
3) in the "Go to directory" Windows, you paste ~/Library/Containers
4) here you find com.apple.TextEdit and you drag it to the Desktop (with cmd key pushed).
5) you reboot your Mac and retry.
7
  • Hi. Thank you for your reply. Sadly, it didn't help. Need to dig further. :)
    – Arsenii
    Nov 25, 2021 at 10:27
  • 1
    That's a shame. Can you create or use a new user, connect with him and try if you have the same problem? You can also try a Safe Boot (push shift key at boot) to suppress system caches.
    – user415185
    Nov 25, 2021 at 10:54
  • Dear @Jean_JD, thank you for your advice. Creating a new user made it work! I am now moving all my settings and files to the new dir. It's sorry Mac Os does not have an ability to restore built-in apps to the initial state. Thank you!
    – Arsenii
    Nov 25, 2021 at 13:52
  • @Arsenii I've a big doubt on this solution. Have you seen my tests in my precedent response?
    – user415185
    Nov 25, 2021 at 13:57
  • you mean this: "I tried on an Intel Mac running Monterey 12.0.1 and easily reproduced the bug"?
    – Arsenii
    Nov 25, 2021 at 14:02
1

I can confirm this bug report. New files can be created and saved but selecting files listed in the Open Recent menu result in a spinning beachball crash. I restarted my Mac laptop running Monterey in Safe Mode. TextEdit opened files from the Open Recent menu without a problem. I have the same model MacBook Pro. I am submitting this answer because my troubleshooting identified a problem in the MacOS kernels, not the TextEdit application. All start-up login items were disabled and thus not a factor.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .