5

I am trying to change the security settings using the Startup Security Settings on my new MacBook Pro (Apple Silicon). I am entering the MacOS Recovery utility by holding down the fingerprint button. When I enter the Recovery Utility I click on Utilities > Security Policy.

At this point I get a popup that says

Security Settings Cannot Be Changed.
In order to change security settings please power off your Mac and then hold the power button to startup in MacOS recovery.

The problem is, I am ALREADY in MacOS recovery. Rebooting and going back to this screen does absolutely nothing.

I have called Apple support and no one has a clue. It has been escalated to level 2 support and I am supposed to get a callback sometime tomorrow.

In the meantime, I have also tried wiping the entire disk partition and reinstalling MacOS 12.0.1 from USB. The outcome is exactly the same.

Has anyone run into this? I need to be able to allow system extensions on the new MacBooks. Thank you

1

6 Answers 6

7

FYI, Aidenbotelho's answer here saved the day for me:

https://developer.apple.com/forums/thread/672184

Crossposting their answer for visibility:

Here’s how I fixed it. so the issue is because on m1 macs each OS installed has its own recovery unlike Intel macs where the recovery was standard among all the OS.

In order to fix it

  • Shut down the Mac
  • Press and hold the power button to access the startup settings.
  • Hit options. This will take you to macOS recovery
  • Once you are in recovery hover over the Apple logo in the menu bar and hit “STARTUP DISK” choose the one where your main OS is and restart.
  • Then open recovery again and voila you can access “startup security utility” properly.
3

For anyone that has this problem in the future, I seem to have solved the problem. The confusing part is that it actually solved itself. I think it has to do with the disk encryption status - while the disk is initially encrypting changing this security setting does not appear to be possible. After coming back to this setting about 6 hours later, it suddenly started working, for no apparent reason.

I tried completely disabling disk encryption and re-enabling it - and at first, it did not work. But after a few hours, the problem suddenly disappeared. So it appears that changing this setting when you first start setting up your Mac is the problem.

1
  • Good job on coming back to answer the question for others. Glad it worked out for you! 🙂
    – dkugappi
    Commented Dec 21, 2021 at 20:44
2

I had the same issue, exact same symptoms as OP. I looked into it further and wonder if during OPs troubleshooting he was entering Fallback Roceovery mode which requires 2 quick presses of the power button and then holding on the second press until it starts to load Start up options. In Fallback rocovery mode you cannot change Security settings in Startup Security Utility. It will give you the same error OP had every single time.

After additional research I was able to fix it by launching in regular recovery mode by pressing the power button once and holding it. That launches into Regular Recovery mode and allows you to make security changes.

I found the answer here. https://iboysoft.com/wiki/fallback-recovery-os-mode.html

2
  • I’m also having the Utility menu doesn’t appear/Seem to be in fallback recovery mode problem. I’ve tried the two solutions referred to from here to get around it but they’re not working. WT, Apple? Contacting them next. Commented May 13, 2022 at 8:44
  • I am not entirely sure, because I tried different things. But I believe, this helped me.
    – Pete
    Commented Nov 8, 2022 at 9:48
0

For anyone who has "FileVault" enabled, try disabling it and then restarting. Much easier than trying to quickly tap the power button to enter Recovery mode when the system prompts you to "Restart." Very very frustrating they use the power button to manage this process; it's very difficult and confusing when the power is coming on or off for the machine. Anyways, disabling FileVault allowed me to get around this.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Dec 2, 2022 at 21:51
0

The correct method to resolve this issue from Apple themselves is:

macOS Recovery requires:

  • The silicon Mac to be shutdown first
  • wait 5 seconds after the screen goes black
  • Then press and hold the power button, don't let go until you see "loading startup options"
  • Then everything will work
  • Same process goes for T2 chip Macs

(if they still don't and your sure you followed all instructions a slight possibly the firmware needs to be revived: but as a last resort)

0

Nothing above worked for me, and it worked when I opened the Fallback Recovery OS, turned off the computer, and then started it in normal Recovery OS. I have no idea why this worked, but if it can help ...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .