0

I've created a bootable installer for MacOS Monterey (on a USB flash drive) using the usual method of downloading the installer and using 'createinstallmedia' within Terminal. The command appears to complete successfully. I've done this before with older versions of MacOS and it's worked fine.

However, the installer I created for Monterey is not working properly. If I startup with the alt-option key and select it, it appears to boot from the USB installer, but my machine boots into recovery mode instead. Further indication that something is amiss is the fact that (when booted into my existing system) that the USB installer does not appear in System Preferences -> Startup Disk (even though it does appear when starting up with alt-option).

I've searched for this problem, and have tried the following, to no avail:

  1. Un-checked the "ignore ownership" box (in Finder -> GetInfo).
  2. Gone to the Startup Security Utility, which says that "Firmware password protection is off".
  3. Verified that my computer (2017 Macbook Air) is capable of running this OS, and of course that the certificate is not expired.

I'm at my wit's end. I've tried creating a bootable installer of Big Sur and have the exact same issue.

I have an old USB bootable installer (for ElCapitan) that seems to work fine - the machine will boot up with it, although it too does not appear in SystemPrefs->StartupDisk.

It's a new USB 3.1 32GB stick. I've formatted with "GUID partition map" and "Mac OS Extended (Journaled)". Here is the 'diskutil' info for it:

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *31.0 GB    disk2
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk2s1
   2:                  Apple_HFS ⁨Install macOS Monterey⁩  30.7 GB    disk2s2

For the record, output of the 'createinstallmedia' command ...

sudo /Applications/Install\ macOS\ Monterey.app/Contents/Resources/createinstallmedia --volume /Volumes/Monterey\ installer
Password:
Ready to start.
To continue we need to erase the volume at /Volumes/Monterey installer.
If you wish to continue type (Y) then press return: Y
Erasing disk: 0%... 10%... 20%... 30%... 100%
Making disk bootable...
Copying to disk: 0%... 10%... 20%... 30%... 40%... 50%... 60%... 70%... 80%... 90%... 100%
Install media now available at "/Volumes/Install macOS Monterey"
17
  • Have you tried another USB stick? Nov 22, 2021 at 20:55
  • No. I'm seeing no indication that it's bad. I got it in a pair with the one I tried to do BigSur on - and neither works. I guess it could be something generic. I don't have any other ones big enough right now. Nov 22, 2021 at 21:30
  • I'm now repeating the download and createinstallmedia to see if that does anything. Nov 22, 2021 at 21:30
  • Nothing works. Tried different USB stick. Couldn't even erase - and yes, I did search for that (69888 error or something). Reset PRAM. Nothing. Nov 23, 2021 at 1:24
  • Have you tried launching the installer application from the flash drive as opposed to directly booting into the boot picker screen?
    – pion
    Nov 23, 2021 at 3:04

1 Answer 1

0

I was experiencing the same problem while trying to get Monterey through USB flash drive installation and resolved this.

To work around this Monterey installation issue:

  1. Install the oldest version available and released with the Mac model with an USB stick (Ex: for my MacBook Air 2018 it is Catalina)
  2. From the current version (i.e. Catalina) download the next version (i.e. I think it is Big Sur)
  3. Create a bootable USB flash drive for this downloaded version.
  4. From the current installed system(i.e. Catalina) and without restarting: click on the installer you see in the usb stick to update the current system to the next one. (install it into a new volume if possible).
  5. If you installed it into a new volume: Reboot on the new system by continuing pressing the Option button while it restarts and select the volume with the freshly installed version of macOS.
  6. Go to step 2.

Do this until you get to Monterey, jumping from one version to another. Some versions can't be installed through USB but the first version seems to be always installable.


Optional: If this still does not work: Erase all volumes by pressing Command+R before you press on the Power button and by using Disk Utils then do a clean install of the previous main system.

Make a volume for each version of macOS with disk utils and when the installer ask for the disk, just select an empty volume so you won't have to repeat it from step 1.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .