2

To get these possibilities out of the way at the start:

  • I'm not referring to a macOS installer (I can do that), but a full macOS with a Finder, etc.
  • I'm specifically referring to a thumb drive (I can do this to an external SSD, but they don't fit in my pocket).
  • I know I use do target disk mode insteal, but that's not always convenient (see fit a Mac in my pocket).
  • Booting from external drives is completely enabled for the T2 macs I've worked on for trying this (again, it works on the external SSD).
  • Multiple drives, multiple sizes, multiple model Macs
  • Catalina and Big Sur both have this issue
  • Most of the machines I've used have never been in Jamf

Here is the setup and my problem: I work on Macs frequently, and occasionally they won't boot. In the last few years, I've used an external boot volume running macOS Mojave to fix machines when this happens. The latest (and last) Intel computers can only run Big Sur and Monterey. So I need to update my thumb drive. When I do this, I start installing macOS to an external volume, I select an external thumb drive that is large enough (64, 128, and 256G drives tested) and formatted for one APFS volume. The installer reboots as expected.

If it's a T2 Mac, the installer continues to the black apple boot screen, but eventually gets in a crash screen loop. If it's a non-T2 mac, it hangs on the black boot screen when the progress bar is half way, even left for a literal week.

Again, this process works for an external SSD, so the process is sound.

The question: What would make the thumb drive act different than external USB drives to cause the failure to complete the installation and can anything be done about it?

3
  • 1
    I'd be tempted to skirt the problem by installing to an internal, then using carbon Copy Cloner to clone it to a USB stick - see if it will boot that way.
    – Tetsujin
    Nov 16, 2021 at 19:22
  • I tried that, but it would only boot the computer I made it with, so it works, but it doesn't work for a multi-computer rescue drive. Nov 17, 2021 at 1:44
  • I've found out that CCC will frequently fail cloning to the thumb drives, but will occasionally succeed. I've posted my process as an answer for posterity. Thanks for encouraging me to keep trying. 1 out of 3 tries still give a solution if you're stubborn ;) Dec 13, 2021 at 16:11

1 Answer 1

1

Not a true answer, but I'm putting this here for anyone looking for info on this situation.

The best I've been able to do is with Carbon Copy Cloner, but it will fail to correctly clone multiple times, so it's a bit of a slog to get through. I've had the most luck with removing the partitions using my linux box

change the drive letter top match yours, as there's no confirmation in this script

echo 'label: mbr' | sudo  sfdisk /dev/sdc && echo 'label:gpt' | sudo  sfdisk /dev/sdc && sudo fdisk -l /dev/sdc

Plug the drive into the Mac and erase it APFS with Disk Utility.

Clone with CCC (Legacy boot assistant).

It's still a "sometimes fails" situation, so YMMMV (I have one drive that I've given up on). I've managed to get 4 drives working, so that should do for now.

1
  • Great use of the answer section to crowd source and edit potential solves. How does the USB drive benchmark in speeds compared to the other external drive. Could this just be a slow controller on the storage?
    – bmike
    Sep 9 at 20:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .