I have a friend with a ~2008 MBPro which has seemingly hit the hay. I'm not 100% it's 2008, but I think so. It has magnetic power cord--the square one.

Anyway, as soon as it turns on, there is the blinking folder icon with question mark. Safe-boot, single user... nothing will boot except the installation CD.

Heres what I've tried:

  • Reset NVRAM/PRAM;

  • Booted with CD;

    -- Repair Permissions: OK; repairs made

    -- Verified permissions: OK

    -- Repair disk: OK; repairs made

    -- Verify disk: OK

  • Tried to select startup disk: HD not available for selection

  • Reset NVRAM; reboot

  • Tried to select startup disk: HD not available for selection

  • Fired up terminal; HD is there, mounted, browsable, and all the files appear to be there. However, permissions seem strange (even after repair)--lots of 501's.


Is there some way to determine if it is reparable with an HD swap? i.e. is there some way for me to determine it is not some other hardware issue?

I had recently (a few weeks ago) added in some more RAM. But, since then, until a few days ago, everything was working fine. When strolling through some logs, I did see a reference to a missing NVRAM variable--but might have been the result of hot-swapping USB... Could an issue with RAM keep the startup disk from working?



The blinking folder icon indicates that the computer can't find a valid startup disk. Based on the tests you've performed, it may that one or more critical files was removed from the drive, but the screwed up permissions are indicative that something is screwy. I would reinstall the operating system.

If there are files on the disk you want to save, copy them off of the drive onto an alternative volume before installing the OS.

  • Thanks. I'm sorry, I should have mentioned in the OQ, when I boot with the CD, the first thing it says is "OSX Can't be installed on this computer". Mar 9 '12 at 15:05
  • What version of the OS are you using? What is the source of the CD—is it a full installer, or an OEM CD that shipped with a(nother) computer? It's also possible to find retail copies that are too old to be used on some computers. Also, be absolutely certain that the drive is formatted using Mac OS X Extended (journaled) and the the partition map scheme is GUID.
    – jaberg
    Mar 9 '12 at 15:09
  • Oh right!! I'm sorry, I keep forgetting what I looked up... I think it is an older OEM Disk I had that is indeed older than the MBPro. They have a backup, so I'll try and talk them into Lion, wipe and restore. Thanks again. Mar 9 '12 at 15:13

If you want to verify connectivity to the hard drive and you have a second Mac with Firewire. You could always boot your MacBook Pro in to Firewire Target disk mode, by holding down the T when booting it. Then simply connect it to another mac via Firewire and you MacBook Pro should mount as a hard drive on the other Mac. If the hard drive has not completely failed this should work fine, also allowing you to make backups of any data left on the MacBook Pro.

Yes it is possible that bad RAM could do this. Eg in an example case of a read from disk of startup info, store it in RAM, RAM corruption, then write corrupt invalid settings to disk, then machine fails to reboot.

Running the Apple Hardware Test or a Memtest program might not be a bad idea to verify the integrity of the RAM modules.

After you do that then reinstalling OS X would be the best move.

  • Occam's razor. We know the drive hasn't failed completely because he was able to run disk repair against it from an external disk. While there is no harm in testing the RAM, it wouldn't be the first place I'd look to solve this problem.
    – jaberg
    Mar 9 '12 at 17:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .