0

System configuration: Mac mini (M1, 2020)
OS: macOS Monterey
Product: Intensity Shuttle
Application: Desktop Video Setup v 12.2

Intensity Shuttle gets detected fine in an Intel-based Mac running Big Sur, but the same device isn't working in macOS Monterey with the Apple M1 chipset.
Exploring this on google and trying different workarounds, I noticed that .kext files are not placed in "/Library/StagedExtensions/Library/Extensions", in-fact StagedExtensions folder is empty after installation of "Desktop Video Setup v 12.2". I tried to install v12 and v11.7 but StagedExtensions aren't getting created. Couple of other workarounds which I have tried but don't work:

  1. Boot in recovery mode, disable csrutil and then install the application
  2. Moved StagedExtensions from Intel-based mac and placed in "/Library/StagedExtensions/Library/Extensions"

None of the above helped in detecting Intensity Shuttle: No Desktop Video Device Detected Although the device is detected fine in System Information; screenshot below: System Information displaying Intensity Shuttle

Kindly help me understand the following:

  1. What is the use of .kext files?
  2. Can these be moved and installed in macOS Monterey?
  3. Is there any other possible workaround to make it work?
3
  • Have you contacted the software/hardware developer?
    – IconDaemon
    Commented Nov 15, 2021 at 1:20
  • Yes, I have. No response yet, probably something which is M1 and monterey specific. Commented Nov 15, 2021 at 6:17
  • I have had this issue with an I7 processor since updating to big sur 2 years ago... was never solved byy either mac or Blackmagic design. It show the device plugged in on the mac, but blackmagic desktop or mediaexpress not seeing the device.... I have a macmini of the same generaton and processor that was upgraded at the same time and it never had an issue with that any of the same blackmagic interface even after the upgrade.... the thunderblt ports appear to be working fine with any other devices... including hub, usb and ethernet interphaces and even HDMI interface to monitors .... Commented Aug 19, 2022 at 19:21

1 Answer 1

1

According to https://www.blackmagicdesign.com/support/readme/33abc1034cd54cf99101f9acd2edd93d Intensity Shuttle doesn't seem to be supported on M1 currently:

Intel Macs only:

...

Intensity Shuttle Thunderbolt

So you have to wait for the vendor to add support for M1.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .