0

I have an old iMac (20-inch, Mid 2007) that has a white screen on boot that shows an EFI drive only and no macOS. I used my Windows 10 laptop with balena.io/etcher to create a live version of Pop!_OS Linux. By pressing the Alt button, I was able to get into the Mac Startup Manager and I was able to plug in the live version of Pop!_OS Linux and see it, However, I was not able to click on it and use it.

Also, when I went into the Mac Startup Manager, I didn't see a partition for OS X. Therefore, I am assuming the drive in the system is dead. So I am just looking to boot from a live version of Linux.

Also, I tried the Linux live drive on a MacBook Pro 2013 and it worked. I’m not sure what to do next with the iMac.

enter image description here

enter image description here

3
  • I’ve added the implied question that makes sense and cleaned up syntax and title with an edit
    – bmike
    Commented Nov 12, 2021 at 12:44
  • @bmike: No, I read the OP starts the Mac and gets a white screen. Next, the OP restarts the Mac and holds down the Alt key to reach the Mac Startup Manager. The image shown appears after plugging in the flash drive. Your edit does not say this. Also, make up your mind. Do you think the screen was white or gray? You should not say the screen was both. (BTW, cmp AA9Jp.jpg KEIOX.jpg shows the images are identical. I do not think the OP meant so show the same image twice.) Commented Nov 13, 2021 at 8:09
  • Bruh: I was reading the last edit you made to your question. I assume you can move the mouse pointer, but can not click to boot. Is this correct? Are you using the wireless mouse that came with the Mac? Have you tried using the keyboard to select? As I stated in my posted answer, I am able to boot and use the live version of POP!_OS. However, my hardware configuration may differ from yours. Commented Nov 13, 2021 at 9:13

1 Answer 1

1

I also have an iMac (20-inch, Mid 2007). I downloaded POP!_OS 20.04 LTS (pop-os_21.04_amd64_intel_10.iso) and used balenaEtcher (Version 1.5.64) on an iMac (21.5-inch, Mid 2011) running macOS High Sierra (Version 10.13.6) to create the live flash drive installer. I was able to boot a live version of Pop!_OS Linux on the iMac (20-inch, Mid 2007). I was using a wired keyboard and mouse. The iMac (20-inch, Mid 2007) has 4 GB of installed memory and was connected to the internet through the ethernet port.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .