0

I have a mac that has remote control set up. I'm trying to ssh (from my own mac) using

ssh username@IP_address

It hangs for a few seconds and then it says operation timed out. Interestingly, I can ping the same IP address successfully. I can also run the traceroute command and see it start from my mac's IP and end up at the target IP in 3 steps.

What is the next thing I can check to figure out why we can't ssh into this machine?

Edit: the output of the ssh command with the verbose mode:

OpenSSH_8.1p1, LibreSSL 2.7.3
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 47: Applying options for *
debug1: Connecting to xxxxx port 22.
ssh: connect to host xxxxx port 22: Operation timed out
12
  • 2
    Try verbose mode and see if that gives any hints: ssh -v username@IP_address
    – Buadhai
    Nov 10 '21 at 4:41
  • @Buadhai I tried it and added the output to the post. Nov 10 '21 at 15:46
  • You get get even more debug output with -vvv, but currently it looks as if sshd isn't running on the remote machine, or at least not accepting connections. Do you have physical access to it so you can verify some things there?
    – nohillside
    Nov 10 '21 at 15:50
  • @nohillside I have verified that the remote machine has ssh working fine, as I can ssh into my own laptop from the remote machine. I tried the -vvv flag but the output is the same as the one with the -v flag. Nov 10 '21 at 20:21
  • 1
    you already did, by running ssh localhost on the remote machine.
    – nohillside
    Nov 11 '21 at 17:57

You must log in to answer this question.

Browse other questions tagged .