2

My MBP 16" (11.6 big sur) has a broken keyboard. Instead of getting it fixed, I have placed a magic keyboard on top of it. Works great and fits perfect (internal keyboard is disabled via karabiner elements).

But the pads under the external keyboard sometimes press the touch id button on the laptop. This causes the laptop to go to the login screen / lock itself. It interrupts my flow.

I'd like to disable "lock laptop on touch id press" behavior, or at least make it only lock after a 1-2s press.

How do I do this?

1 Answer 1

0

On my Macbook Pro with Monterey 12.4, I disabled the instant-lock behavior of the TouchID button by running this command in a terminal:

defaults write com.apple.loginwindow DisableScreenLockImmediate -bool yes

The Apple developer documentation says that this will work in macOS 10.13 and later.

5
  • Doesn't seem to do help on Big Sur. Will try to upgrade.
    – surj
    Jun 5, 2022 at 0:37
  • 1
    It works on Monterey (12.4) !! Thanks!
    – surj
    Jun 11, 2022 at 7:34
  • 1
    It still works on Ventura (13 beta2)
    – surj
    Jul 4, 2022 at 18:55
  • Unfortunately, this command also disables the "Lock Screen" item in the Apple menu. Feb 3 at 1:20
  • To solve the issue where the CMD+CTRL+Q or the "Lock Screen" item in the Apple menu is disabled, use a script to enable/disable when needed. <br/><br/> ~ % cat ./disableScreenLock.sh <br/> defaults write com.apple.loginwindow DisableScreenLockImmediate -bool yes <br/><br/> ~ % cat ./enableScreenLock.sh <br/> defaults write com.apple.loginwindow DisableScreenLockImmediate -bool no
    – Arthas
    Apr 9 at 8:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .