Mavericks Update

Sadly this issue remains unresolved in Mavericks.

End Update

When I run Migration Assistant (from an admin account) in Lion, M.A. hangs at the message Migration Assistant "Looking for Other Computers". The Time Machine disk is not seen even though it is connected through USB and it is the Lion TM disk from the same machine.

I tried:

  1. Pressing the greyed-out 'continue' button.
  2. Having the Time Machine both selected as the TM disk, or connected without being selected.
  3. Rebooting into the recovery partition and attempting recovery from TM. At least in that case the TM disk is seen, but it cannot be used because "only full Mac OS X backups can be restored". I only save user files on TM.

What are some other ideas I could try? I prefer to avoid running a 'cp -pR', but if you think I could get away with it, please mention the caveats.


I've had a similar problem, which may be different to your problem because all the computers in my house share the same backup drive, and so there are lots of different backup files.

My problem (which I fixed) was that Migration Assistant couldn't see the backup drive, but it turned out that if I opened the drive in Finder, and then opened the '.sparsebundle' file that belonged to my computer, then all of a sudden the backup drive became visible to Migration Assistant and I could restore from backup.

| improve this answer | |
  • Right, double-click on the sparsebundle file does the trick – sglessard Nov 22 '12 at 15:27

Apple's official suggestion is to turn off your firewall, so you could try that. Other alternatives are to make sure you run Software Update on both computers, and monkey some with Internet sharing, both of which are described in their official support article on Migration Assistant.

I had encountered nearly this same problem, but on first time setup of a Retina MBP. Initially I thought your attempt to click the greyed out continue button was silly, but I learned my lesson when I was flummoxed by this screen:

MacBook Pro Lion transfer from Time Machine source selection

It turns out that even though the "Looking for other computers" wheel is spinning, and even though the Back button is a tempting blue, and even though the Continue button is greyed out by comparison (a UI convention implying 'disabled' that dates back several decades), and even though there's a giant action verb ("Select") on top of the screen, and even though there's a large icon of your Time Machine volume that feels selectable, the intended user interface element for you to click here is the Continue arrow. Took me about 30 minutes and a couple dozen Google searches before I thought to try that.

Which I post only because there are tons (seven threads on Apple's forums in the past month, as of this writing) of people getting stuck at "Looking for other computers," and I'm just hoping that a few of them are not in fact having the deep technical problems they imagine, but are rather merely as confused by this screen as I was. (Wishful thinking, I realizeā€¦)

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .