1

I'm having an issue where I can connect to my personal hotspot from my MacBook Pro to my iOS devices, but I do not get any data. I've tried a bunch of things but no luck.

Interesting info:

  1. My iPad can connect to my phone and get data just fine
  2. My MacBook can connect to both my phone and my iPad, but no data either time
  3. All devices are from the last few years
  4. Tethering via cable also doesn't work
  5. I'm not sure about bluetooth tethering as I can't get it to work. I paired with iPhone but when I now click to connect to my phone in the list of bluetooth devices on my computer, it briefly connects and then immediate disconnects.

I have tried various solutions from around the web including:

  1. Being on the latest and greatest OS versions on all devices
  2. Restarting all devices (it's persisted also through major software updates)
  3. Removing all wifi SSIDs that include the name of my phone from the saved networks
  4. Removing the wifi interface from my Mac and re-ading it
  5. Turning on/off iCloud Private Relay on both devices
  6. Removing other DNS, renewing DCHP
  7. Disabling my second SIM - the network I want the data from is the default network and the physical SIM
  8. Last night I formatted my Mac and still no luck!

It seems like potentially a DNS issue - if I ping google.com I cannot get through. However if I ping 8.8.8.8 or 1.1.1.1 I do. In fact I can visit https://1.1.1.1 in safari!

3
  • Interesting. Sensible initial steps. Some troubleshooting from the command line with arp -an and ping and ifconfig should help indicate where the problem is. Also, you haven't mentioned if they're connecting over Wi-Fi or bluetooth or USB cable. Nov 5, 2021 at 1:56
  • Added info on cable tethering and using ping Nov 5, 2021 at 7:57
  • Glad we figured it out. Nov 13, 2021 at 20:24

2 Answers 2

1

It seems you may just be lacking a working DNS configuration.

If iCloud Private Relay is on, your DNS queries from Safari should go through the relay, not go straight to your ISP. IF they go to your ISP via the relay, the ISP's DNS servers are not likely to respond. Why? Typically, it's advised when setting one up to serve a network's own users, to NOT allow a DNS server to act as a public DNS server. So since it's likely your ISP isn't running a public DNS server, it won't respond to queries that appear to come from outside its network. (The few companies that do run public DNS servers generally don't use those same servers to host the DNS records of their own domains.)

However, if retesting confirms that "Turning off iCloud Private Relay on both devices did not fix the issue." then there's another problem as well. (Could be the problem I identified plus bad caching.)

1

In my case this was indeed a DNS issue. I hadn't changed any DNS settings (and I even formatted my Mac to make sure things weren't in a bad state)

As a recap, I could ping IP addresses fine including my default DNS server from ISP and 1.1.1.1 and 8.8.8.8 but I couldn't resolve domains.

Turning off iCloud Private Relay on both devices did not fix the issue.

Explicitly setting my DNS to my ISPs DNS server did not fix the issue.

However, explicitly setting 1.1.1.1 as my DNS server (on my MacBook Pro) did fix the issue.

Additionally, after turning iCloud Private Relay back on, it didn't break anything. Which is weird since it explicitly says on the DNS screen that while it's Private Relax is on, you can't manually set DNS settings.

Because of that I'm still not clear on exactly why this happened but hope that helps someone. And I'm curious if anyone has theories on what it was?

1
  • LOL. I meant to post the answer I just posted here as a comment/reply to your new/final question but it actually works as an answer, so leaving it. Nov 13, 2021 at 20:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .