0

System: macOS 11.6.1, MBP 2019 16in

I am having a persistent issue with certain tags. I have a tag, call it "post", that I use as a toggle. I set it on files that I need to find to upload to a certain cloud site. I set it on files that I need to attach to an email. I set it on files that I need to deliver in a presentation. After I have done the action with the files, I unset the tag.

The tag resides in my sidebar as a favorite. It is colored yellow.

My problem is, the tag sometimes refuses to be unset. It refuses to be unset in a rather disturbing manner. It refuses to be unset to disappear from the favorite list but it shows no tag in the Finder list view. Here is a view with the ghost-tagged file and a valid-tagged file.

ghost tagged and valid tagged

I have tried these four options:

  • I have toggled the post tag on and off to the file using the favorites view. While I do this, I see the xattr com.apple.FinderInfo and com.apple.metadata:_kMDItemUserTags toggle on and off (see further below).

  • I added the folder containing the file to the Spotlight "do not search" preference pane (Privacy) to delete the Spotlight index. The ghost-tagged file disappeared from the favorites list. I rebooted. I removed the folder from the Spotlight do not index list. The ghost-tagged file reappears.

  • I used various approaches with xattr to view the meta attributes and remove them with -dr. I found that I could remove all xattr characteristics. The ghost-tagged file seemed to drop from the favorites. But when I clicked to a different favorite tag and returned to the post tag ... there was the ghost-tagged file again and it had absolutely no meta-xattr settings.

  • I have deleted the post tag entirely using the Finder preferences. I then created a new tag with the same name. The ghost-tagged file reappears.

  • I used OnyX to remove the Spotlight index file.

A slight wrinkle perhaps. I have my internal hard drive partitioned into three volumes. Some of the above disaster happens with files that are on other volumes.

Another slight wrinkle perhaps. I am using DevonThink to index portions of the external volume that contain the files. I looked at the DT database for the tag. It shows no file is contained in that tag.

What puzzles me primarily is what else I should be doing to purge the ghost tag definitively. Should I boot into safe mode to purge something? Should I rinse the file through some secondary app to remove the tag (the files are primarily PDFs, and I have rw access to them as seen in the Finder info box)?

My reading suggests this may a problem without an answer, or the answer is fairly deeply hidden. Any thoughts would be appreciated, even if only to confirm that this mystery is just one of those hidden gems in using macOS.

0

1 Answer 1

0

I developed this exact issue on Monterey and also did not have success with other proposed solutions including rebuilding the spotlight index or deleting the finder plist.

The problem was immediately solved when I disabled FileVault, even before decryption was complete. Fortunately, the problem did not return when FileVault was re-enabled. I've seen other people online with this issue as well - hopefully this fixes it as I haven't seen anyone suggest this solution yet.

1
  • I am not using FileVault, so this is not the culprit. Thanks. Commented Oct 28, 2023 at 15:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .