3

I'm running VirtualBox 6.1. After the upgrade to macOS Monterey, my VM's fail to start up with the error message

Kernel driver not installed (rc=-1908)

I tried reinstalling VirtualBox and, while that worked at the moment, the problem began again when I turned on my computer the next day.

Based on similar questions on this site, I checked System Preferences -> Security & Privacy. However, there's no pending request from Oracle.

3
  • Output of kextstat | grep -v 'com.apple'?
    – Joy Jin
    Nov 3, 2021 at 3:56
  • Executing: /usr/bin/kmutil showloaded No variant specified, falling back to release Index Refs Address Size Wired Name (Version) UUID <Linked Against> Nov 3, 2021 at 23:11
  • Sorry, I misread the system version. I believe from macOS 11 Kernel extensions are deprecated; instead Apple wants people to use system extensions. So you will need to follow this guide to enable loading of kernel extensions: developer.apple.com/documentation/apple-silicon/….
    – Joy Jin
    Nov 4, 2021 at 1:15

3 Answers 3

4

Does Oracle claim VirtualBox supports Monterey? It seems not, although there are workarounds.

https://forums.virtualbox.org/viewtopic.php?f=39&t=104272&sid=69ae383878d1d0b9a0e676592adeb79a

3

I was getting the same error. I then ran sudo kmutil load -p '/Library/Application Support/VirtualBox/VBoxDrv.kext' and the error went away.

2
  • Huh. That worked! What exactly did that do? Nov 4, 2021 at 23:50
  • Also, I have to re-run that command whenever I restart my host computer. Nov 5, 2021 at 14:38
3

With an update to Virtualbox 6.1.30 macOS Monterey is supported. This includes headless operation from posts on their beta forum.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .