15

Whenever I try to mute my Bluetooth audio input (mic) by either applying a shortcut with the following code set volume input volume 0 or by manually minimizing the sound to 0 on Sound Preferences -> Input, I receive unwanted behavior: All my audio (both input and output) is muted, then if I modify the output audio, I got immediately unmuted.

Also, from the additional observations:

  1. This only happens when I got both Input and Output set to my Bluetooth headphones and mic
  2. Mute works fine when applied to the MacBook Pro Microphone input source
  3. When I navigate to Sound Preferences -> Input, while listening to music, the audio quality degrades dramatically.
  4. It all started happening after I upgraded to macOS Monterey and worked completely okay in macOS Big Sur

Could you please advice of how this issue can be resolved?

Thank you!

UPD as of 12/14/2021

The issue persists in the Monterey 12.1.

UPD as of 02/01/2022

Still not fixed in 12.2

UPD as of 03/01/2022

Still not fixed in 12.2.1

UPD as of 03/15/2022

Still not fixed in 12.3

2
  • 1
    Still not fixed in 12.3.1
    – oborovyk
    Commented Apr 14, 2022 at 19:38
  • i read on reddit that disabling "airplay receiver" in preferences → sharing solves this? can anyone confirm/refute this?
    – Robin
    Commented Apr 28, 2022 at 22:00

7 Answers 7

7

There’s a bug in macOS Monterey when using Bluetooth headphones. Any time a Bluetooth headset’s mic is muted, the output is muted as well

4
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Nov 5, 2021 at 3:19
  • 2
    Not really a source but the FAQ for the app Mic Drop has a mention of this bug, saying it was reported to Apple. getmicdrop.com/help
    – mfilej
    Commented Nov 22, 2021 at 15:02
  • 1
    My temporary workaround to this bug is to mute then quickly volume up with my external keyboard button to bring back the audio output.
    – f01
    Commented Jan 4, 2022 at 21:14
  • I got another workaround. I have a tool that controls muting only non-bluetooth devices. I got the hint from this page retina.studio/ears/monterey-mute
    – f01
    Commented Jan 10, 2022 at 16:06
3

It appears to have been fixed with macOS Monterey 12.4 I have just updated to.

Steps to verify:

  1. Connect bluetooth headphones.
  2. Follow Sound Preferences -> Sound -> Input.
  3. Play some music.
  4. Drag the input volume slider all the way to the left.

The sound should not be muted when dragging the input slider to 0.

2
  • 1
    I can confirm it's finally fixed on 12.4 🎉
    – Mika A.
    Commented May 18, 2022 at 5:43
  • Same here my app that mutes (not just volume zero) the Bluetooth microphone do not mute my sound outputs anymore.
    – f01
    Commented May 18, 2022 at 22:41
1

i ended up just saving the current output Volume in a variable before setting input to 0, then reset output to the original value.

tested in phone calls and while listening to music, the output volume switch to 0 and back up so quick that it is not noticable (least for me)

Sample code on Gitlab and below.

#!/usr/bin/osascript

# Required parameters:
# @raycast.schemaVersion 1
# @raycast.title muteme
# @raycast.mode silent

# Optional parameters:
# @raycast.icon 🤖

# Documentation:
# @raycast.author cy


on getMicrophoneVolume()
    input volume of (get volume settings)
end getMicrophoneVolume

on getOutputVolume()
    output volume of (get volume settings)
end getOutputVolume

if getMicrophoneVolume() is greater than 0 then
    # remember outputVolume original value
    local outputVolume
    set outputVolume to getOutputVolume()
    
    # set input volume to 0, (mute)
    set volume input volume 0

    # set output volume back to original value (in MacOS Monterey this gets set to 0 when input Volume is being set to 0)
    set volume output volume outputVolume 
    
    
    say "muted" using "Samantha"
    display notification "Microphone Muted"
else
    set volume input volume 100
    say "unmuted" using "Samantha"
    display notification "Microphone Activated"
end if
1
  • Hi, simply using this sequence may work in your "muting" code part : "set volume input volume 0" then "set volume without output muted" Commented May 9, 2022 at 9:29
0

Yes, there is a bug in macOS Monterey.

Here are the steps to reproduce:

  1. Connect any bluetooth headset to the computer.
  2. Open the "audio MIDI setup" application which is a default macOS application.
  3. Find the headset you connected via bluetooth and find it on the input pane it might show up as two separate devices.
  4. Play any audio source (maybe play clip from youtube).
  5. Go back to the "audio MIDI setup" application and click/check the mute checkbox next to the slider on the input pane.
  6. At this point the output will be muted; what should happen (desired behavior) is the input should be muted but it should not impact the output.

This is not the desired behavior.

Hopefully someone at Apple can fix this soon.

0

I use a third party app to mute my mic. When the mic is muted, the audio drops on my AirPods as well. This issue only started after I updated to macOS Monterey. Hopefully someone found a fix or Apple fixes this with an update - this is clearly a bug and I have it too.

0

Working as of 06/06.
macOC Monterey 12.4.
Try MuteKey!

0

Was fixed for me in MacOS 12.4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .