32

After a recent update to my Pi-hole server, I'm now seeing the warning "Your network settings prevent content from loading privately" above email messages in the Mail apps in iOS/iPadOS 15.x and macOS v12 (Monterey) when I'm connected to my home Wi-Fi, preventing me from using the "Protect Mail Activity" feature in iOS 15.

1 Answer 1

44

Recent versions of Pi-hole automatically sink hole requests to two key Apple domains (mask.icloud.com and mask-h2.icloud.com) to prevent the Apple Private Relay feature from bypassing Pi-hole. Due to this, the "Protect Mail Activity" feature in iOS 15 may not work when connected to a network using a Pi-hole server.

In iOS, the "Protect Mail Activity" feature is found under SettingsMailPrivacy Protection. In macOS, it's found under MailPreferencesPrivacy.

To resolve this, add the BLOCK_ICLOUD_PR=false setting to your Pi-hole server's pihole-FTL.conf file using the following steps:

  1. SSH to your Pi-hole server
  2. Run the following command: sudo nano /etc/pihole/pihole-FTL.conf
  3. Append the following setting to this file and save the file: BLOCK_ICLOUD_PR=false
  4. Either restart your Pi-hole server, or just restart the DNS Resolver service with pihole restartdns

Pi-hole documentation: BLOCK_ICLOUD_PR=true|false (PR #1171)

2
  • 8
    This is a fine, fine Q&A. Much obliged
    – bmike
    Oct 31, 2021 at 21:29
  • 1
    It should be noted that this may cause traffic to bypass the Pi-hole, i.e., instead of more privacy you may actually get less. Tracking may be obscured though the privacy relay, however, telemetry sent by the Apps may contain sensitive information and will not be blocked anymore.
    – MrD
    Nov 6, 2021 at 20:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .