As the title suggests, I upgraded my mac to Monterey today, and since then I am not able to use any VPN on it.

No idea why that's the case, I tried HMA (Hide My Ass) and Nord. In my networks, it says that VPN is connected, but the internet doesn't work.

I am using a 13" MacBook Pro 2018 and the VPN connect - but then no application that goes to the internet works.

Do I need to select a VPN provider that can support me or is this an easy fix for general VPN?

  • Does the problem only occur in Safari or in all applications which requiring network access?
    – nohillside
    Oct 31, 2021 at 8:35
  • 1
    in all the applications which require internet
    – Manan
    Oct 31, 2021 at 14:28

2 Answers 2


Try disabling Private Relay (System Peferences > Apple ID > iCloud > Private Relay).

macOS Monterey comes with a new feature called Private Relay which routes traffic through an Apple relay so your Mac has different IP address as seen from the WAN side. The aim of this is to protect your privacy. However, VPN services can be confused by the changing IP addresses.

Also see https://support.apple.com/en-us/HT212614

  • Does Private Relay impact all Internet traffic or only Safari?
    – nohillside
    Nov 2, 2021 at 9:10
  • 1
    @nohillside Not 100% sure, but while Apple mentions Safari in the linked document, it also says that if a service or network doesn’t work, it should be tried to switch off Private Relay. It’s been reported that VPN failures are connected to Private Relay and that disabling it helped.
    – not2savvy
    Nov 2, 2021 at 9:17
  • this feature is premium (at least for my account, in Europe) and disabled, but I'm also having trouble accessing company web sites with Safari over a working VPN connection...
    – Gregor
    Jan 10, 2022 at 14:54
  • That’s true. If I enable our company VPN, Private Relay refuses to work.
    – not2savvy
    Jan 10, 2022 at 15:29
  • For me, turning off private relay helped me get started with IPVanish app not able to download configuration files or 'invalid configuration' file issue on macOS 12.7.1. And once after that I was able to turn on private relay. I am using Wireguard protocol.
    – Arun
    Nov 8, 2023 at 16:53

If your VPN (L2TP over IPSec) works properly but you cannot connect to the internet. This is what helped me out. The solution is to add the Google's DNS server to your DNS list.

  1. Make sure you have "Send all traffic over VPN connection" selected


  1. In addition to the IP that you probably can see here grayed out. Add the following IP (You could provide any other IP to the DNS provider of your choice)

DNS Settings

Now VPN should work just fine.

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jan 15, 2022 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .