5

I have a 2017 27in retina iMac booting off of a (stable) DIY m.2 usb drive (controller: Realtek RTL9210 NVME). I upgraded to Monterey (public release - NOT beta) on Oct 25, the day it was released. It seems to have installed macOS 12.0.1. It upgraded and booted fine, and I interacted and configured the system (I changed app settings that were new with Monterey). When I shut it down (night) and booted it up (morning), the boot progress bar wouldn't cross 1/2 (everything else was normal). I tried booting in safe mode, but got no luck. I reinstalled Monterey with recovery mode (DID NOT WIPE DISK). However, I had the same issue. I tried safe mode again, no luck. I reset NVRAM and tried again, safe and non-safe (no luck). I booted into verbose mode to get the output, and it didn't seem like something I could fix. Here is the output:enter image description here

Finally, I tried booting on a 2015 iMac 5K. No luck there either.

I needed my Mac, so I reinstalled Big Sur (fresh) from an external boot drive and used a TM backup to restore my data. Unfortunately, this means I cannot perform any more tests.

My main questions are, what went wrong (curious), and if/when I can install Monterey again (I would highly prefer upgrading, even if I have to wait a month or 2). I would prefer not to, but am fine if I need to re-install Big Sur, but I would not like to right now, so I will most likely execute suggestions in a month if there is not a high level of certainty.

P.S: the only kernel extension I have that I know of is VirtualBox

Thanks again to all who answer my question.

Edit: see the solution I posted

2 Answers 2

3

Are you using external hard drive? Some people reported extremely long boot times (30+ minutes). Try to leave your mac booting for an hour, maybe it will boot up. If that's the case, as for temporary solution: let your mac sleep, instead of shutting down, till fix comes out. https://discussions.apple.com/thread/253302798

It seems there’s a problem with USB devices: https://discussions.apple.com/thread/253303875 https://discussions.apple.com/thread/253308334 Try to remove all external peripherals while booting up, including mouse and keyboard.

Another similar issue:

https://www.reddit.com/r/hackintosh/comments/qgcw3z/long_boot_after_monterey_update/ Maybe try to disable bluetooth

I have 2017 iMac 27 retina myself, it boots in 20 seconds, internal SSD.

2
  • Thanks for the input. I am using an external SSD. As I stated before, I had to downgrade my main machine to big sur, so I can't test. However, I have a 2015 iMac and clean external drive that I can install Monterey on to test. If this is the issue, ill wait a month before installing Monterey, as for my main machine, turning off Bluetooth (due to trackpad gen1 - no lightning) or waiting an hour for boot are not viable options.
    – anonymous
    Oct 29, 2021 at 20:33
  • I tried to recreate the issue with a 2015 iMac and a sata ssd, but I can’t recreate the issue. From the threads you provided, it seems to be an issue with Realtek rtl9210 nvme, and I won’t try on my main machine, as I need that to remain stubborn. Real bummer that I have to stay on Big Sur for the next month, as I was counting on hopefully getting a Big Sur 11.6 issue with my monitor and the passwords tab.
    – anonymous
    Oct 30, 2021 at 0:00
1

To help anyone with a similar issue, I got a jm583 enclosure from Amazon, swapped my Big Sur ssd into there, booted and upgraded to Monterey, and then the Mac booted in 2 minutes (versus 30). However, this still was not normal speed (45 sec), so I did a clean install and restored from a TM backup. After doing this, the boot time was reduced to 45 seconds in the JM583 enclosure. When I tested switching back to the (better) Realtek enclosure,the boot time increased back to 20 minutes, so I had to (and you will have to) permanently switch to your new enclosure.

*edit: my boot time went back to 2 mins after restoring. I guess ive just put so much on my mac that it boots slower now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .