1

I regularly use Zoom links, and I want it so that I don't have to click allow every time I open the zoom link. Specifications: Safari 15.1, macOS Monterey, and have a MacBook Air M1 late 2021. I've tried going to safari preferences and allow popups, but I still have to click allow every time even after allowing popups.

2 Answers 2

1
  • Go to Safari Settings > Websites
  • Choose "Pop-up Windows" on the left side
  • Select "Allow" for specific websites and/or "When visiting other websites"
3
  • I did that, but it's still not working for zoom. Every time I open a link, I am forced to click the Allow button Commented Oct 27, 2021 at 2:04
  • Could you show us the exact message/button in a screenshot? Commented Oct 27, 2021 at 9:24
  • @KevinGrabher They are referring to the alert that appears when you click Join Meeting, it's not a regular popup.
    – Ezekiel
    Commented Oct 27, 2021 at 19:18
0

You cannot disable this prompt with Safari alone.

If you regularly join the same meeting code, you can create a link to it that goes directly to the Zoom application and bypasses Safari:

zoommtg://zoom.us/join?confno=123456789&pwd=xxxx
2
  • I tried that, but I'm still forced to click the Allow button every time. It works in Firefox and Chrome... I think it is a Safari problem. I've switched to Firefox instead. Commented Oct 28, 2021 at 14:51
  • It will work if you don't use the zoommtg link in Safari. You can use that link in other applications (such as a file bookmark or a Notes entry)
    – Ezekiel
    Commented Oct 28, 2021 at 14:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .