9

I have a 1TB OWC Aura Pro X2 on my MacBook Pro (Retina, 15-inch, Mid 2015) model. I'm currently running macOS BigSur 11.6.1. When I tried to upgrade to macOS Monterey the update fails with a generic message saying:

An Error Occurred While Preparing the Installation ...

In the logs, I could find errors highlighting that the EFI drivers are outdated. I checked the OWC website and I could not find any firmware update matching the current macOS that I have. Any pointers on how to solve it?

2
  • I have a 1TB OWC Aura Pro X (not X2, so maybe unrelated) but I see the same issue in my MBP mid-2015 trying to upgrade from 11.6 (Big Sur) to Monterey. If I watch the macOS Installer Log it gets to the point where it calls bless and says in "BLESS STDERR" "EFI found at IODeviceTree:/efi" and then says "Bless failed with error num: 3". Googling thus far is inconclusive. Hope the similar report helps and/or someone else comes up with something.
    – Mike Hardy
    Oct 26 at 16:51
  • 1
    I have the OWC Aura Pro (Not X). I am seeing this same issue. I tried to install via safe mode and got the more detailed message "a required firmware update could not be installed. Compatible internal storage is required in order to update. Oct 26 at 18:57
13

I may have a workaround to share that got me going...

https://discussions.apple.com/thread/253296956?answerId=256166114022#256166114022

I ran into the same issue and contacted OWC to see if they had a firmware update available for my SSD. Talking to support, they said that it isn't the SSD that requires the firmware update, but the MacBook Pro itself, which requires an EFI update that won't be installed unless there's an Apple SSD installed. They recommended that I reinstall the original Apple SSD, then install Monterey to get the EFI update, then replace the Apple SSD with the OWC SSD, and upgrade from Big Sur 11.6.1 to Monterey. According to OWC, they've tested this fix in their lab and it works.

1
2

No me too ... I tried a fresh install also fails during boot time of Monterey.

First did an install from Big Sur also an error when trying to shut down.

Put back the original SSD, installed Monterey succesfully ;)

Then placed the OWC Aura X2 pro back, the upgrade to Monterey did succeed, so also for me the procedure described in this chat worked.

So for everyone that still has the original SSD... this solves the issue ;)

0
1

Use the original SSD.

I confirm the following worked great for me on my 2015 MacBook Pro 15".

  1. Installed original SSD.
  2. Installed fresh copy of Monterey via the USB stick onto the original SSD (it rebooted a bunch of times, indicating a firmware update).
  3. Put the new SSD back in.
  4. Booted off USB stick and upgraded to Monterey without a hitch.

It sucks if you don't have your original SSD but maybe you can get a cheap one off of the interwebs. Doesn't have to be big. Likely doesn't even have to be the same one that came with your unit. Most likely just any genuine Apple SSD.

Good luck.

1

Swapping out my OWC drive for original Apple drive on my 13 inch early 2015 MBP did allow the update to complete. Once that was done I reinstalled the OWC drive and had no problems upgrading to Monterey.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .