2

I've just updated my mac to Monterey and after that I found out that font is just different that it used to be before the update - the tab title is quite small and fonts on websites are both different and missized:

Web fonts comparison, Chrome (left) vs Firefox (right)

Firefox (top) vs Chrome (bottom)

It seems the FF option Allow pages to choose their own fonts, instead of your selections above is not working anymore as from what I understand it should load website based fonts instead of the one you select in FF settings (I have it checked obviously). I haven't try to reinstall the FF yet but maybe there is a way to fix it without doing so?

I use Macbook Air with M1 chip.

3
  • 2
    See bugzilla.mozilla.org/show_bug.cgi?id=1732629, seems to be a known issue (which apparently doesn't happen to everybody).
    – nohillside
    Commented Oct 26, 2021 at 9:13
  • Strange, I've been googling the issue but couldn't find any bug like this reported... Anyway, thanks for the heads up I will keep monitoring this thread! Commented Oct 26, 2021 at 9:26
  • This is really a question that should be addresses to mozilla
    – mmmmmm
    Commented Oct 26, 2021 at 11:28

2 Answers 2

2

As explained in https://bugzilla.mozilla.org/show_bug.cgi?id=1715898#c5 this bug currently occurs if macOS 12 has a non-english primary language set. As a workaround the primary language can be set to English in System Preferences (at least in my case no reboot was required, it was enough to restart Firefox afterwards).

0

I had the same problem. Roboto font would show up severely mangled, and completely unreadable.

Removing the font via Font Book and reinstalling it did not help. Eventually, I did the steps in the Reddit post Fonts screwed up on FF 94.0

You also could look at modifying this preference (recently renamed) so that exotic fonts on your system aren't plugged into web pages:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste layout.css.font-visibility and pause while the list is filtered

Firefox should display a family of preferences starting with that string:

(3) Double-click the layout.css.font-visibility.standard preference to display an editing field, and change the value to 2 then press Enter or click the blue check mark button to save the change. Note: web fonts are not affected, sites can still use those freely.

The available values are:

  • 1 - among locally installed fonts, only expose base system fonts in web content

  • 2 - also expose fonts from optional language packs

  • 3 - also expose user-installed fonts [default]

Does that make any difference?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .