Shows error popup Unable to verify macOS when I tried several times to upgrade macOS from BigSur to Monterey. Also tried this answer but not working.

  • Error Screenshot : error dialog

  • Log Screenshot : Logs

Installer log :

2 Answers 2


Got same error here, i think that this line matters: Oct 26 12:26:09 Aayushs-MacBook-Pro osinstallersetupd[965]: Personalization summary: 20G165 -> 21A559 (Customer), global = 0, variant = multiple, client = osinstallersetupd, user auth = 0, tdm = 0, prod fused = 1, model = j132ap, bridge = 18.16.14759.0.1,0, session = 1377012F-B0D8-4061-8C5A-23057FB93DCE: Error Domain=OSPErrorDomain Code=201 "An error occurred during personalization." UserInfo={NSLocalizedDescription=An error occurred during personalization., NSUnderlyingError=0x7fe18798ab70 {Error Domain=AuthInstallErrorDomain Code=14 "(null)"}} I think it's due to you're in a VPN network or sth that makes apple think that you're in a different country? I solved it by turning off my VPN agent.

  • 1
    My vpn was not turned on. But I guess my university internet blocked this update server site. So when I connected to my personal wifi It worked! Oct 29, 2021 at 4:26

This is how I solved it on my Intel MacBook Pro 2019. (Mac M1 info here) The first step was probably unnecessary, as it found no problems.

  1. Restart and use Cmd+R at boot to enter recoveryOS and run Disk First Aid on the main drive.
  2. Restart and use Cmd+Opt+R to boot into the Internet recoveryOS and install the latest macOS
  3. Get brunch/supper/play some games while your Mac grinds away for an hour or two. It will restart a few times.
  4. Hello Monterey!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .