1

I have 2 Gmail accounts hooked up to Mail. One is an @gmail.com account, the other is a business account run through Google Apps.

When I send an email from the business account, the email always shows up in my Inbox as if the message was sent to me.

The "Automatically Cc or Bcc me" checkbox is unchecked in the "Composing" section of the Preferences.

If I send the email from the gmail website, no problems occur. If I send an email from my "@gmail.com" address the problem does not occur.

Anyone have any advice?

  • If you use Mail to send a message from your business account, then check your inbox via the web interface, is it in your inbox there, or just in Mail? – Timothy Mueller-Harder Mar 8 '12 at 21:41
  • @TimothyMueller-Harder : It is in my Inbox on the web interface as well. – James P. Wright Mar 9 '12 at 15:14
2

I've solved the problem for my own use. The problem for me was a glitch in gmail itself. Elsewhere the question was asked, does this behavior happen with messages sent from the gmail web interface as well? If those messages are also showing up in your gmail inbox, it's probably not a Mail fault. Check your gmail filters for the following:

When you use a filter with the "never send to spam" option enabled that is (accidentally perhaps) matching message you send, they will show in the Inbox.

This is considered by some to be a gmail bug. The solution is:

The filter does the same thing as the "Not spam" button, which puts the selected conversations in the Inbox. You can exclude sent mail from your "Never send to spam" filters by including "-me" in the From field, or by adding "-from:me" in the "has the words" field.

In my experience it is not necessary to fully comply with Google's recommended settings for IMAP accounts, namely that you should uncheck the box to "Store sent messages on the server." I very much want to leave this selected, and having it selected is now working fine for me, now that I have added the "-me" exception to the misbehaving filter.

Refer to these threads for further background: https://productforums.google.com/forum/#!topic/gmail/hdItaHiUAgc https://productforums.google.com/forum/#!topic/gmail/NI1aRo6SvTc

1

If you're retrieving your mail from the account in Apple Mail using POP, I had a similar problem and it turned out to be because My 'Sent Mail' is downloaded to my POP inbox. Changing to IMAP solved it using Google's recommended IMAP settings.

Alternatively, it might be because conversations are enabled in gmail.

1

I believe I have fixed the issue. It seems that my SMTP for my business account was offline and was using my SMTP for the regular Gmail account.

As soon as I got it back online and told it to use the SMTP for the business account it no longer shows up in my Inbox.

I have no idea why it was doing that, but this seems to have fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .