1

I have run into the issue where no matter what files/applications I delete I cannot actually free up any disk space on my Early 2014 Macbook Air with 128GB of SSD storage. The most recent exercise was to delete Xcode ~10GB. Before the delete, the storage summary showed 3.6GB of free space. After the delete, the storage summary showed ~4.8GB of free space. What did change was the allocation between "Applications" and "System". Before the delete, System was 82GB, and Applications was 20GB, afterwards, Applications went down to 11GB, and System went up to 92GB.

Here are the items I have tried / won't consider trying:

  1. Yes, I have emptied the trash multiple times
  2. Yes, I have booted into safe mode and then back into normal
  3. No, I won't install a third-party piece of software to delete screensavers/applications backgrounds, logs. When interrogating Library and System folders those folders do not show 90GBs of usage they show something like ~10GB
  4. Yes, I have tried finding the listing of Time Machine backups and deleting them (there are none listed)

So hopefully someone has encountered this issue and found a substantive solution. I am personally wondering if the "cloud" drives I have installed are just consuming all of the free space (I have two providers).

For reference, I am running macOS 10.14 (Mojave)and I am unable to install the latest update because I cannot free up enough space on the system to do so!

3
  • 2
    What are the results of the terminal command tmutil listlocalsnapshots /?
    – user415185
    Oct 24, 2021 at 18:12
  • Inspect what is taking up the storage on your drive. Either use a 3rd party software (OmniDisk sweeper is free and reliable in my experience) or make yourself familiar with the necessary Terminal commands if you refuse to install 3rd party software for the task. Oct 25, 2021 at 9:37
  • local snapshots are empty. Nov 2, 2021 at 22:44

1 Answer 1

0

Debug what exactly is occupying your disk space. CleanMyMacX or Finder is not good for this, because it lacks permissions and doesn't include system files with root privileges. The solution below requires some manual work and OS understanding, since you're (was) using XCode i think you should be fine:

The solution for debugging disk space:

  1. Open up Terminal.App
  2. cd /
  3. sudo su
  4. du -hs *
  5. Look for weirdly unusual high folder sizes
  6. cd "/usr" (for example)
  7. du -hs *

Repeat steps (5-7) till you find the weird looking files. Once you identify the problem look online for solution. Once, I had an error log filled up to 50GB, i did the following steps and solved the problem ;) Or you could simply try CleanMyMacX's Space Lense. GL

1
  • Thanks for the detailed steps on du. This was helpful in confirming that either the command line isnt giving me a clear picture about space on the disk, or its Macos. Command line confirms only 60gbs of usage (when running du on root), but Macos "About > Storage" shows only 2GB of free space Nov 2, 2021 at 22:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .