0

I just exchanged my 2 TB HDD in my A1419 27" 5K late 2015 iMac to a 2 TB SSD (before that, it was part of a Fusion Drive configuration). Now I went into recovery mode on startup and tried restoring from that backup via network. The drive appeared as it should, and the backup, too, but every time I try to access it, it fails with error 112. I then tried to access the backups from another Mac in the network, and Time Machine nicely shows me all the backups and I can open up the last one and see all folders and files. So what's the problem here? I'm using a Synology NAS and usually connect it with SMB.

Here is your diskutil

enter image description here

4
  • What is the format of your new internal SSD? Can you, from terminal in Recovery Mode give the results of the command diskutil list internal?
    – user415185
    Commented Oct 21, 2021 at 4:32
  • I linked the output from diskutil list("internal" would just give me an error?).
    – cirko
    Commented Oct 21, 2021 at 15:56
  • What was the system installed before you replace the disk? And would you recreate a Fusion Drive or separate the two SSD (128 g and 2 To)?
    – user415185
    Commented Oct 21, 2021 at 16:47
  • I'd prefer recreating a Fusion Drive again. Previously, there was macOS Big Sur installed, with an additional Windows Bootcamp partition. I'm just trying two workarounds: Firstly, simply restoring macOS and than migrating with Time Machine - maybe it'll open then; or secondly, transferring the TM backups to an external disk I can directly attach.
    – cirko
    Commented Oct 21, 2021 at 16:53

1 Answer 1

1

For restore your Save Big Sur, you need a disk or Fusion Dive with APFS format.

In Internet Recovery Mode with no system installed on the internal disk, the system offert is the initial system of your Mac. So you can't create a container with APFS format with a system older than High Sierra.

The solution is :

  1. create an Big Sur installation usb key from an another Mac : https://support.apple.com/en-us/HT201372

  2. boot the Mac with this key and create a fusion drive from the terminal :

    diskutil resetfusion

  3. verify the new organisation on your disk :

    diskutil list internal

  4. If you have a new Fusion Drive with an APFS framework, you can either install Big Sur and use the TM Backup Migration utility to retrieve your information, or use the TM restore directly.

2
  • This solved the issue, but I'd like to point out that I think the main part of the solution was to use a Big Sur installation USB stick. The recovery mode is a bit different from the pre-installed one, and Time Machine opened the old images without any trouble. I think there was an underlying incompatibility issue of the Time Machine version used for the backups and the one in default Recovery. But probably I couldn't have restored without the APFS disks either. Thanks!
    – cirko
    Commented Oct 27, 2021 at 8:07
  • Happy for you. ;-)
    – user415185
    Commented Oct 27, 2021 at 9:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .