Tried to start my Macbook last night but would restart as soon as it reached 50%~ on the progress bar. When trying to boot into a recovery mode it would restart at about 30% on the progress bar and my windows 10 install would also fail to boot. Made a Big Sur install USB on another computer and that too restarts after 30%~.

So far I've tried:

  • PRAM Reset
  • SMC Reset
  • Disconnected Battery
  • Removed SSD
  • Different 85W Magsafe adapter
  • Big Sur Installer USB (Without Battery or SSD after failing with them).
  • Thunderbolt Ethernet Adapter in both Thunderbolt ports

None of which have changed the restart point. Did have a "Service Recommended" notice on the battery (Serial is not covered under Apple's recall, either not affected or previous owner did it), hence testing without the battery, was undervolted and wattage limited with Volta. Has Catalina, Big Sur and Windows 10 installs on it (Can see all in bootloader).

Screen appears to have yellow hue in top left corner, red in top right and bottom left corner, which I don't remember seeing before.

Thanks for any help.


I reopened the Macbook and noticed some very minor corrosion/some sort of goop on the magsafe connector, small enough I wouldn’t have cleaned it if I did not have an issue. Ended up removing the entire logic board to check the underside at the same time and saw nothing on the backside. Decided to connect the SSD, IO board and boot it with a USB Mouse and Keyboard on a HDMI monitor. Booted right up and did the sensor freak out with Fans at 100% usage and CPU locked to 800mhz and iGPU with 0.00GHz request (Intel power gadget). Catalina, Big Sur and Windows 10 all worked fine although device manager in Windows gave the GPU a code 43 error and a facetime camera error (Wasn’t connected). Slowly pieced the machine back together after this and if I connect the trackpad connector the fault returns, this connector also needs to be connected for the keyboard to work it seems. Battery is completely dead even though MacOS says it holds charge, unplugging magsafe with “55%” charge just instantly kills the machine.

  • stack exchange just suggested a post mentioning Big Sur 'bricking' SSDs from 8 months ago, I'll try a Catalina installer USB now. This shouldn't effect it since issue remained when trying to boot without an SSD??
    – Nich201
    Oct 16, 2021 at 9:04
  • Let's see where in the boot process this occurs. Please boot in Verbose Mode (hold CMD+V as soon as you hear the boot chime) and take a slow-mo video of your screen as the console text is scrolling. Then please upload individual framegrabs from the video to your question so that we can try to read the console log and determine at what point the restart happens.
    – pion
    Oct 16, 2021 at 18:41
  • Also, if you boot into the Boot Picker (hold Option during boot) or Target Disk Mode (hold T during boot) and let it sit for 10 minutes, does the machine remain stable or does it reboot as well?
    – pion
    Oct 16, 2021 at 18:44
  • It remains stable in Boot Picker for however long it sits. As for Verbose mode I've been unable to get a not blurred slow motion of the entire process but it crashes immediately after the line: RLF, old date swfs_pld_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>apfs_load_lnode_Internal: 4887: *** reset lno 12886467967 size back to 0 (from 271) which is after the "Early boot complete. Continuing system boot." message, can try to fish out other details if needed, just need to piece it together from multiple blurred videos.
    – Nich201
    Oct 16, 2021 at 20:38

1 Answer 1


Failure to boot different OSes and different devices suggests a hardware failure outside the disk. You need to take this to an Apple Store or other authorised Apple technician.

Also, your Mac needs a battery and internal storage unit for proper functioning. Removing them is not going to improve things.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .