1

I have a 2020 MBP running Catalina. I have a Magic Keyboard with no Touch ID and a number pad and everything works fine. I also have a smaller Magic Keyboard (also no Touch ID) and no number pad and whenever I press the media keys it just sends the Fn key. My Touch Bar doesn't show the function keys unless I press Fn, and holding Fn on the keyboard makes them show up on the Touch Bar. I've tried two keyboards.

2 Answers 2

1
  • Disconnect the Magic Keyboard with Num Pad
  • Go to System Preferences > Keyboard
  • Uncheck "Use F1, F2, etc. keys as standard function keys on external keyboards"

If this does not help, go to Bluetooth settings and remove both external keyboards. Pair the one without Numpad, repeat the steps above, then pair the Magic Keyboard with Numpad.

4
  • 1
    I had come across these steps before I posted but I don't see the f1, f2 etc keys... option in my settings, do you know where else it might be? i.imgur.com/PoPEjEG.png This is also where the apple website says they should be Oct 14, 2021 at 19:06
  • Which version of macOS are you running? Oct 15, 2021 at 10:15
  • 1
    Catalina (10.15.7) Oct 15, 2021 at 17:08
  • 1
    There seem to be more people with the issue (there are a few posts on other forums that describe the option as missing). Some reported that plugging in an old USB keyboard temporarily helped, try that if you have one around or maybe try plugging in your Magic Keyboard and see if the option re-appears? Oct 16, 2021 at 11:19
1

This ended up being an issue with Macos Catalina. Upgrading to Big Sur fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .