So, Time Capsule and Time Machine together used to be the perfect backup solution for my household's Macs. Then they stopped working.

After I got a new laptop with Catalina, I would regularly get an error message saying that the backup needed to be deleted and was starting over. Sort of defeats the purpose of a backup when it gets regularly deleted. Then my wife started getting the same error on her computer... and then it got even worse on mine, where it just wouldn't back up at all.

Since my wife is also getting problems on her computer, it doesn't seem like the issue is with my setup. I started looking for alternative backup solutions. I tried Carbon Copy Cloner and Super Duper, and they both took an interminably long time... and then failed anyway.

I would imagine that a big part of the problem, if not the whole problem, is just that Apple isn't supporting Time Capsule anymore. But it is supporting Time Machine, I think. So it looks like what I need is a good third-party wireless router that will support Time Machine. But before I blow hundreds of dollars, I wanted to check in with people who know what they're doing. If I buy a good third-party Time Capsule equivalent, will that allow me to go back to the old way of using Time Machine? And are there particular things that I should look for in the hardware to make that happen?

  • You have to wonder if the problem is the hard disk in the Time Capsule. Oct 13, 2021 at 18:58

1 Answer 1


Time Capsules are still fully supported up to the lastest macOS (currently Big Sur).

Time Machine is the software part of it all. Time Machine will perform recursive backups to

  • an external drive (USB, Thunderbolt, FireWire, ...)
  • a Time Capsules internal drive
  • an external drive connected to an AirPort/Time Capsule via USB
  • any Time Machine compatible network device (most reputable NAS brands and some routers)

To start troubleshooting your issue I would recommend you reset your TimeCapsule, format the HDD and reconfigure (deactivate, reactivate) TimeMachine on all Macs.

You could further try to see if the issue occurs when an external drive is connected to your TimeCapsule (this would rule out the TimeCapsules internal HDD as a source of error).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .