2

I have a file server (SMB/Samba 4.5.16) in the local network. If I put a .dmg file on it (anywhere) and try to mount it, MacOs will ALWAYS verify it first, which means reading through the whole thing, which takes almost 30 minutes for a 200GB file over GBit Ethernet.

So again, the scenario is: An SMB server exports a share, I mount that normally on the Mac (which works fine), the share contains a .dmg file, I try to mount that, the .dmg file gets verified. Every time. After that, the mount succeeds and I can use the dmg's filesystem without issue, but the 30 minute verification is a total show stopper.

I tried the following things, none of which help (all from How do I skip verification of a .dmg file?):

# Disable the "Are you sure you want to open this application?" dialog
defaults write com.apple.LaunchServices LSQuarantine -bool false

# Disable Disk Image Verification: Verifying ...
defaults write com.apple.frameworks.diskimages skip-verify -bool true
defaults write com.apple.frameworks.diskimages skip-verify-locked -bool true
defaults write com.apple.frameworks.diskimages skip-verify-remote -bool true

Mounting the thing with hdiutil attach -noverify mounts the filesystem read-only -- useless.

This is an M1 Mac running Big Sur. I had an Intel Mac running Catalina before, and I didn't have this problem with that. The file mounted almost instantly (i.e. no verification), from the same file server.

If I copy the file to the local disk and mount it from there, it works without verification.

How do I fix this? Is anyone doing this successfully, and if so, which file server and MacOs version are you using?

1 Answer 1

1

Update: I just updated to Monterey, and it looks like they fixed this. Whatever. Miracles do happen. 😎

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .