1

I had an old 2017 MacBook Pro that was wiped and sent away. My problem is I need to get a file from a Time Machine backup that I have of that machine stored on my Synology NAS. I use this NAS as a Time Machine backup disk for all of my Macs. I'm able to mount the Sparsebundle on my 13" M1 Macbook Pro but I can't see any files. What I really need to do is go back to a certain date to recover a few megabytes worth of text files. Here is what it looks like in Finder when the sparsebundle is mounted:

View of the sparebundle file system in Finder when mounted

I tried holding down the Option key and clicking on the Time Machine icon to "Browse Other Backup Disks". I'm able to find the drive I'm looking for but the interface to go back in time freezes and is unable to go back or display other dates.

Trying to browse the volume in Time Machine

Exploring the sparesbundle on the file explorer on the NAS shows files and there is data in the bands folder. The sparsebundle weighs in at about 144GB so I'm confident I should be able to access my deleted files on it somehow. I don't see a Backups.backupdb folder.

View of the sparebundle from my NAS' file explorer

I tried downloading the sparsebundle locally and messing with it on my local hard drive instead of over the network but it doesn't seem to make much of a difference.

I got desperate and fired up the Migration Assistant app to see if I could restore the Time Machine backup to a fresh account but after a few hours staring at Loading Backup... I gave up.

Migration Assistant stuck loading the Time Machine disk

Any other ideas on how I can access this Time Machine backup to recover a few files?

1 Answer 1

1

@kingkool68,

You may have moved on from this, but just in case you're still trying to recover the files you need... The website http://www.schwie.com/brad/?p=806 cobbles together sparsebundle and backupbundle repair instructions (including a shell script) that may be of use to you:

  1. Disable Time Machine on your Mac, in my case from my MacBook Pro -> go to System Preferences…->Time Machine->uncheck box for “Back Up Automatically”.

  2. Save this script to your Desktop and name it TimeMachineRepairScript.sh:

    #!/bin/bash -x
    
    # Generally based on ideas found at:
    # http://www.garth.org/archives/2011,08,27,169,fix-time-machine-sparsebundle-nas-based-backup-errors.html
    # 
    # Reduced the ideas there down to their essentials.
    # 1. Unlock the image.
    # 2. Reset the saved failure in the backup metadata.
    # 3. Verify/fix the filesystem.
    
    # Take the arg. You did provide an arg, right?
    IMAGE="$1"
    
    if [ -z "$IMAGE" ]; then echo "usage: $0 image_path"; exit; fi
    
    # Repair the stupid file lock.
    chflags -v nouchg "$IMAGE"
    chflags -v nouchg "$IMAGE/token"
    chflags -v nouchg "$IMAGE/bands"
    
    # Fix the plists
    /usr/libexec/PlistBuddy -c "Delete :RecoveryBackupDeclinedDate" "$IMAGE/com.apple.TimeMachine.MachineID.plist"
    /usr/libexec/PlistBuddy -c "Set :VerificationState 0" "$IMAGE/com.apple.TimeMachine.MachineID.plist"
    
    # Start bailing on errors (can't set earlier due to PlistBuddy)
    set -e
    
    # Attach the image.
    DEV=`hdiutil attach -nomount -noverify -noautofsck "$IMAGE" | awk '/HFS/ {print $1}'`
    echo "$IMAGE -> $DEV"
    
    # Fix the FS.
    fsck_hfs -fy -c 8gb "$DEV"
    
    # Detach it.
    hdiutil detach "$DEV"
    
  3. Open a Terminal window and and type this, but don’t press enter yet on the last command and leave this window open, we’ll be coming back to it in Step 4:

    cd Desktop
    chmod +x TimeMachineRepairScript.sh
    ./TimeMachineRepairScript.sh
    
  4. Connect the Time Machine disk, locate the name of your backup and drag its icon to the Terminal window in Step 1 and release.

  5. Press return in the Terminal window.

  6. After the script successfully completes repair of the backup, reenable Time Machine on your Mac.

1
  • It would be best to summarize the linked information in case sometime in the future someone else has the same problem they can reference the summary if the link ever dies.
    – agarza
    Feb 22 at 22:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .