1

I'm having the common issue where I have a ridiculous amount of storage taken up by "other", and have enlisted disk drill to help work out where the culprits are.

In disk drill, I have ~90Gb taken up by by library, 83Gb of which is attributed to ~\InstallerSandboxes\.PKInstallSandboxManager\ which then holds six folders, all of which are from what look like Xcode updates (folder\root\application\ is Xcode.app in all six)

disk drill screengrab

I tried restarting in safe mode to clear the caches, however storage still is showing 100Gb+ in other, and disk drill shows the same image, however now when I navigate to the folder in finder, none of the folders within \.PKInstallSandboxManager\ are visible, and the folder itself, along with the other file in \InstallerSandboxes\ are greyed out.

finder

I've made sure that hidden files / folders are visible, and have found various other threads about folders being inaccessible, and have tried to amend the folder date as this seems to be a recurring issue using SetFile -d ..., but get the following error:

❯ SetFile -d '10/10/2021 00:00:00'/Library/Apple/System/Library/InstallerSandboxes/.PKInstallSandboxManager-SystemSoftware
ERROR: Unexpected Error. (-5000)  on file: /Library/Apple/System/Library/InstallerSandboxes/.PKInstallSandboxManager-SystemSoftware

From here I tried changing permissions in the various folders in the path but that's not fixed it. I've also tried moving the folder in terminal to a Temp folder using mv /Library/Apple/System/Library/InstallerSandboxes/* /Users/<username>/Desktop/Temp, however that gives the error zsh: no matches found: /Library/Apple/System/Library/InstallerSandboxes/*

I'm at a total loss as to where to go from here and can't deal with 80+Gb being lost.

2
  • I am not sure what effect deleting these directories has on the system. It would be nice to do a Time Machine backup or a system clone first. What is your system version? You can try suppress this folders from the terminal in Recovery mode (cmd+r at boot). Then you can navigate to /Volumes/Name_Volume/Library//Apple/System/Library/InstallerSandboxes/.PKInstallSandboxManager-SystemSoftware and try suppress directories with rm -r *activeSandbox
    – Jean_JD
    Oct 12 at 5:34
  • I’ve tried your suggestion however and just get rm:*activeSandbox: No such file or directory
    – askman
    Oct 12 at 10:03
0

I tried a few things after this - booting in recovery as per Jean_JD's suggestion, but that didn't show any of the folders within .PKInstallSandboxManage. I tried just rm -r .PKInstallSandboxManage which made the folder disappear in terminal whilst in recovery, but the folder was back once I rebooted properly.

What seemed to finally do the trick was dragging the .PKInstallSandboxManage folder into a new note in apple notes, waiting a couple of seconds and then double clicking on the hyperlink that appeared.

.PKInstallSandboxManage is still greyed out, but the internal folders became accessible and I could then delete them from my system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .