2

An old (mid-2010) iMac 27" with MacOS 10.11.6 behaves quite normally otherwise, but ignores iOS devices (tried with iPhone 12, iPhone SE1 and iPad mini 2):

  • They do not show up in the system profiler as USB devices
  • The devices do not even recognize the iMac as charger
  • A single time I got the message to unlock the phone to connect to the device, but I could not reproduce this

Basically it's like there is no connection at all, but

  • All devices behave normally on a MacBook Pro 2012
  • I tried with two different cables (both work on the MacBook)
  • Other USB devices behave normally on the iMac, including an external hard disk drive, so it's not a question of VBUS power supply either

iMac works, USB works, VBUS supply works, cable works, devices work. What other cause is left?

I only need a one-time-connection to pair the devices to get them to sync via WiFi.

Please, before marking this as duplicate, check the sypmtoms are really the same. I did not find an answer among similar questions.

Update: In the konsole, when plugging in one of the devices, I get

11.10.21 16:43:37,000 kernel[0]: 049596.304561 AppleUSB20HubPort@fd130000: AppleUSBHostPort::disconnect: persistent enumeration failures
5
  • Are there any system updates available? Try softwareupdate -l -a in the Terminal.
    – lhf
    Oct 11, 2021 at 13:35
  • It still ought to work on El Cap. Tested with Mac running iTunes 12.8.2.3 - first request is the 'update' popup, support.apple.com/en-gb/HT208831 & it works after that.
    – Tetsujin
    Oct 11, 2021 at 14:00
  • @lhf "No new software available."
    – Philippos
    Oct 11, 2021 at 14:38
  • @Tetsujin Same iTunes version here
    – Philippos
    Oct 11, 2021 at 14:41
  • Are you unlocking before physical connection or after? tbh, I can't figure out why it's not registering even for power. When I ran my test, the [locked] phone went into charging mode even before I got any visible reaction from the Mac. iOS 14.7.1, old 6S. Tomorrow I could test with an SE 2… when it arrives ;)
    – Tetsujin
    Oct 11, 2021 at 16:03

1 Answer 1

1

El Capitan is pretty old you might need to update the machine High Sierra which is the latest Apple certified version to work with a mid-2010 iMac.

Otherwise here are some steps you might want to try:

Rebooting the iMac

Ensuring the devices are unlocked when plugged in.

Do you have iTunes on that iMac? The software might be old enough that it's required to sync the devices.

1
  • Yes, iTunes is needed, but available. According to the iPhone 12 system requirements, 10.11.6 is sufficient. And: Before any compatibility check with the drivers, the device needs to show up at USB enumeration, which doesn't seem to happen.
    – Philippos
    Oct 11, 2021 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .