1

I'm experiencing inconsistent pop/clicks when using my new AKG k371-BT bluetooth headphones. This happens on both Spotify and YouTube.

The sound is very inconsistent and I wonder if it has something to do with codecs/aac/aptx or pairing issues.

I've ran bluetoothd in console and this came out when I switch on the headphones:

2021-10-07 11:09:14.740 bluetoothd[2209:335455] [establishKernelConnection] Received an error from IOServiceOpen() - 0xe00002c7.  NULLing out io_service_t.
2021-10-07 11:09:15.132 bluetoothd[2209:335455]  [DaemonHandleLinkKeyRequest]
2021-10-07 11:09:15.133 bluetoothd[2209:335455]  [HandleLinkKeyRequest] we don't have a link key for that device.
2021-10-07 11:09:15.136 bluetoothd[2209:335455]  [HandleLinkKeyRequest] Exiting with result: 0x0.
2021-10-07 11:09:15.795 bluetoothd[2209:335455]  [DaemonHandleLinkKeyRequest]
2021-10-07 11:09:15.796 bluetoothd[2209:335455]  [HandleLinkKeyRequest] we don't have a link key for that device.
2021-10-07 11:09:15.806 bluetoothd[2209:335455]  [HandleLinkKeyRequest] Exiting with result: 0x0.

This leads me to believe it's like a driver issue of some sort.

Alot of stuff online states to download Bluetooth Explorer and toggle the AAC/APTX settings, but I can't even get that to download as the apple dev site just sends me to a contact us page.

I've paired the headphones to my iPhone and they work fine. So this issue seems to be with the macbook pro (mid 2015).

Sound Preference show Format is set to "2-ch 32bit Float 48 Hkz" and I only have one other option of 16bit, which is really bad sounding.

Can anyone offer some suggestions on how to fix this problem?

0

You must log in to answer this question.

Browse other questions tagged .