1

i am trying to download homebrew for coilsnake (a earthbound rom editor) among other things but every time i try an install i get curl: (35) error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version i figured curl or opensll were too outdated but to update curl or opensll i need brew, ive tried changing preferences and updating everything i can think to but there doesnt seem to be anyone else with a similar problem online and cannot think of what else to do, please help.

Update: mere minutes after posting i realised i was being stupid and could use macports to download a newer curl however i now have a new problem, i get past giving my passowrd then get Homebrew is only supported on Intel and ARM processors! despite being on a intel mac (though it is fairly old being from late 2006)

1
  • As macports works Why don't you use Macports for all the extra software. What software do you need Homebrew for which is not on Macports?
    – mmmmmm
    Oct 7 at 12:50
2

A few comments on this.

First Homebrew only actively supports the last few (possibly 3) versions of macOS. Also as the Installation docs say

macOS Requirements

A 64-bit Intel CPU or Apple Silicon CPU

macOS Mojave (10.14) (or higher)

with footnote

10.14 or higher is recommended. 10.9–10.13 are supported on a best-effort basis. For 10.4-10.6 see Tigerbrew.

Thus Lion is explicitly not supported and running on a 32 bit Intel is not well supported

Secondly as you note Macports can be installed on Lion. Macports is actively supported on all macOS from Tiger onwards. (PPC, 32 and 64 bit Intel and Apple Silicon)

Why don't you use Macports for all the extra software. What software do you need Homebrew for which is not on Macports?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .