2

How can I disable on the Apple Magic Keyboard the :

  • lock button (above the Delete) : i press it accidentally sometimes and the computer instantly locks
  • the FN button's Input source switch functionality (has a globe icon)

Thanks !

1

Disabling the lock key

I'm not certain that this is possible, but there are two potential approaches you can try pursuing to achieve this.

Karabiner-Elements

The preferred approach would be to use Karabiner-Elements to rebind that key. You'll need to use the Event Viewer utility in Karabiner to determine the key name.

Possible alternative

A possible alternative approach that may or may not work at all would be to see if the solution in this answer could work here. I do not have high hopes for it to work in this case, but there's a slim chance that it could work.

Note that this alternative would have the (possibly undesirable) side effect of disabling the "Lock Screen" keyboard shortcut.

Disabling the function key input source switching

On macOS 11+ (Big Sur or later)

Open System Preferences and navigate to the Keyboard settings (System Preferences → Keyboard → Keyboard). There should be an option "to change input sources by using the Fn key or the Globe key", which should currently be enabled. Disable this option.

Prior to macOS 11

Based on Apple's documentation alone, it's unclear if the option described above is available on macOS versions prior to macOS 11 (Big Sur).

References

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .