1

Mostly just want clarification on why macOS is doing this:

On a fresh install I tried to use the strings command in Terminal and a pop up came up.

enter image description here

I chose to "Install" and waited - it stuck. I quit and tried again and the install completed into /Library/Developer/CommandLineTools/usr/bin/.

Indeed strings was installed among other tools. But looking inside /usr/bin/ strings already existed. They are different sizes and have different modification dates.

% which -a strings
/usr/bin/strings

% type -a strings
strings is /usr/bin/strings

% type -a /Library/Developer/CommandLineTools/usr/bin/strings 
/Library/Developer/CommandLineTools/usr/bin/strings is /Library/Developer/CommandLineTools/usr/bin/strings

% type -a /usr/bin/strings 
/usr/bin/strings is /usr/bin/strings
john@Johns-iMac bin % info /Library/Developer/CommandLineTools/usr/bin/strings

% echo "${PATH//:/\n}" 
/usr/local/bin
/usr/bin
/bin
/usr/sbin
/sbin

/Libary/Developer/CommandLineTools/usr/bin/ is not in my path.

I assume I am able to run strings now, after this download, because it needs some code inside the download to function properly? Seems odd to install an incomplete executable to begin with.

Also, is this enough to satisfy a Homebrew install or will I need to download Xcode Command line tools as well, are they the same thing?

Thanks for any insights on why.

2

This is normal: Certain commands on macOS are installed as placeholders so that when you run them they can be installed, rather than simply saying the command was not found.

The command will work as expected now, there won't be a noticeable difference except that technically there is a wrapping layer that calls the actual executable.

You should not worry, this is the same for all installs. You can proceed to install brew.

1
  • Thank you! Using the method that Terminal suggested doesn't install the latest version of Developer Tools. After installing homebrew I was warned that I didn't have the latest version installed. It may also be because I don't have Xcode installed and therefore was never notified to update it to v.13 - IDK.
    – John
    Oct 4 at 23:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .