1

I'm trying to update Xcode, but it is stuck (this is what it looks like). Other posts I've seen suggest a bunch of different things, each of which didn't work for me:

  • waiting overnight for it to install didn't fix it

  • downloading the package from Apple's developer page worked in terms of installation, but the app itself doesn't work. When I downloaded it, the updated Xcode opens (stored on my Desktop), but it freezes when I try to do anything. Here is the relevant console output when that happens:

More than one bundle with the same factory UUID detected: { "FC0957C6-10A1-469B-AA54-5A9FFE718A93" = MetadataImporterPluginFactory; } in CFBundle 0x7f8f6fd18410 </Users/[my name]/Desktop/Xcode.app/Contents/Library/Spotlight/uuid.mdimporter> (not loaded) and CFBundle/CFPlugIn 0x7f8f71829000 </Applications/Xcode.app/Contents/Library/Spotlight/uuid.mdimporter> (not loaded)

  • I've tried restarting my computer, which didn't fix it (it just made me redo the whole update).
  • When I try to cancel the installation, nothing happens. This is the console message:

Received request to cancel install but we are past download and there is no current interface to stop a PackageKit install

2

1 Answer 1

0

Completely uninstalling the old version (the one that was stuck updating) and using the version I downloaded from Apple's developer page worked.

2
  • How did you go about uninstalling the stuck version? May 5 at 1:16
  • When I did this, app store noticed the reinstall after a while and tried to resume the stuck update again, so I still can't run XCode. (Monterey, XCode 13)
    – O'Rooney
    May 26 at 22:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .