I have nothing related to jdk11 in /library/Java/JavaVirtualMachines but still i see java version is 11 when i run java -versions . Steps i tried

  1. restarting mac
  2. testing in new terminal after closing it .
  3. Uninstalled java on mac by following official link

My goal is to setup jdk1.8 because jdk11 throwing multiple plugin and dependencies sync error with jdk11 when i create android project in android studio .

I am using jdk1.8 in android studio but mac java persist and override it with jdk11 when i launch "Java -version " in android studio terminal.

My environment : MAc OS Big sur 11.5.2 MacBook Pro

enter image description here

  • Are you sure you are looking at the /Library in the root directory - not the Library folder in your home directory?
    – greg-449
    Sep 24, 2021 at 11:47
  • 1
    Android Studio come with its own JRE, clould that be the issue ?? - have a look here as well: stackoverflow.com/questions/19608742/… Sep 24, 2021 at 12:02
  • And a JRE can't be used for compiling code. Sep 24, 2021 at 12:08
  • Try which java to locate the Java installation folder.
    – Andrew T.
    Sep 24, 2021 at 12:34
  • which java /usr/bin/java but where is /usr/bin... sorry for asking such a silly question my user is sX46TA Sep 25, 2021 at 20:17


You must log in to answer this question.

Browse other questions tagged .