0

I've been using the Magic Trackpad 2 for about a month now and recently I noticed that there is no response at worst and delayed response at best on the right hand side of the trackpad. The problem is only in a specific region of the trackpad, about 2-3 cm from the right edge of the trackpad covering the total area from bottom to top. Center and left side work perfectly fine.

I connected the trackpad with my iPad and there were no issues, the right side worked perfectly fine. I also found another thread on Macrumors where people were looking for a solution to the same problem and some of them had trackpad's older than 2-3 years. Mixing that with the fact that the trackpad worked properly on my iPad, I concluded that it is probably not a hardware problem and the software is causing the issue. I'm currently using Big Sur and iPad OS 15.

I've already reset the bluetooth module, factory reset the trackpad, removed the device and reconnected it. Nothing seems to solve the problem. Is there any other solution for this?

Note - I've asked a similar question on Superuser, after going through the guidelines of stack exchange and reading multiple answers about cross-posting. I figured this is one of those exceptions where the question is suitable to both the communities. I've added a link to that question below.

https://superuser.com/q/1677848/1543655

3
  • Please do not post the same question on multiple Stack Exchange sites. Commented Sep 23, 2021 at 19:28
  • I think you need to talk to Apple about this.
    – pion
    Commented Sep 23, 2021 at 20:22
  • A good way to trouble shoot would be to test your trackpad with another Mac and another trackpad with your Mac. If you don't have access to any of the two, perhaps consider a visit to a service provider. Commented Sep 25, 2021 at 13:43

1 Answer 1

2

After struggling with this problem for about a month and being told by apple CC to visit the nearest service centre, I decided to tinker a little more with the settings and see if I can find some sort of solution. This works, but it comes at the cost of not being able to use the two swipe gesture for the notification bar.

Disable Notification centre gesture

  1. Make sure the trackpad is connected to your Mac
  2. Click on the apple logo on the top left hand side of your screen
  3. Click on system preferences
  4. Go to Trackpad
  5. Go to More Gestures
  6. Deselect Notification Centre

I recommend before disabling the notification centre gesture, do the following:

Reset the macOS Bluetooth Device List and Bluetooth Controller

  1. Open System Preferences and click on bluetooth, enable the option Show Bluetooth in menu bar ( If you can see the bluetooth icon in the menu bar move to step no. 1 )

  2. Hold down both the Shift and Option keys and at the same time click on the Bluetooth icon in the menu bar. Once the menu is showing, release the keys.

  3. From the Bluetooth menu, click on Remove All Devices

  4. Hold down both the Shift and Option keys again and at the same time click on the Bluetooth icon in the menu bar.

  5. From the Bluetooth menu, click on Reset the Bluetooth Module

  6. Restart your Mac

  7. Setup your Magic Trackpad 2 again

Note - This will reset all connected bluetooth devices, so all connected bluetooth devices will need to be reconnected.

If this doesn't work then you'll probably have to keep the notification centre gesture disabled to be able to use the right side of the trackpad. Hopefully there'll be an update soon which will fix this probelm.

1
  • This is exactly what I was looking for. I couldn't figure out why sometimes when i went to move the mouse nothing happened, turns out it was the damn delay they put in there waiting for the second finger to trigger the notification centre gesture. Disabling the Notification Centre gesture results in perfect movement every time!
    – Deminetix
    Commented Aug 26, 2022 at 11:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .