I've had to reinstalled OS X Server on 2 Xserve machines. The first went fine. See this link for some background.

When I went to the second machine, everything seemed to go OK. As it takes 30 minutes or so for the installation to copy and install files, I got that far and went out to run a few errands while it finished. When I got back, the display had gone black.

I have a mini DisplayPort cable from the server to an iMac. Pressing Command ⌘+F2 switches between the iMac's display and the attached server.

This worked fine all the way through the reinstallation on the 1st server and fine with the second until I got back from my errands. I've also tested the iMac with the first server; it works fine, so no problem with the iMac or switching it to show the display of another machine.

Having just done the install, but not the setup, yikes! What do I do now? The machine hasn't shown up on the network yet, I may have not connected to the network yet.

Should I just shut it down and restart it?

Can I do a controlled shut down from the attached keyboard with some key sequence or combination (again with now view of what's going on)?

Seems like I have either:

  • a mini DisplayPort cable that suddenly went bad;
  • a mini DisplayPort on the Xserve that suddenly went bad;
  • or some kind a controller glitch or failure.

I can only get to the mini DisplayPort cable if I shut down the servers and roll out their cabinet (I have well ventilated but tight quarters).

Seems like I have to restart. Will I need to re-reinstall?

Any thoughts on the best way to do this appreciated.


The solution to this problem required reinstalling the operating system. It worked seamlessly the second time around.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .