4

I can manually navigate to ~/Documents/untitled folder in the Finder:

enter image description here

But if I use "Go to Folder"…

enter image description here

Finder cannot navigate to ~/Documents/untitled folder, and instead falls back to the root of my hard drive:

enter image description here

Snooping the file syscalls reveals that two file open syscalls were attempted, and that neither encountered any errors:

sudo opensnoop 2>/dev/null -ef '/Users/birch/Documents/untitled folder' 
  UID    PID COMM          FD ERR PATH                 
  501  17873 Finder        21   0 /Users/birch/Documents/untitled folder 
  501  17873 Finder        21   0 /Users/birch/Documents/untitled folder

I get this exact same behaviour when I try to drag-and-drop a path within ~/Documents into a file picker dialogue (navigates to Macintosh HD instead of the intended filepath).

The space in the filepath is not the problem (I get the same results with simpler filepaths).
The tilde in the filepath is not the problem (I get the same results with paths under /Users/birch/Documents).

I can navigate just fine to ~/Documents itself, but no deeper.
I can navigate just fine to ~/Music/iTunes; this problem seems to solely affect "files under ~/Documents".

cd ~/Documents/untitled\ folder in Terminal works perfectly.

The permissions of ~/Documents is the same as ~/Downloads. ~/Downloads works, yet ~/Documents doesn't:

ls -l ~ | grep -E '(Documents|Music|Downloads)$'
drwx------@  425 birch  staff       13600 25 Aug 09:22 Documents
drwx------@ 1205 birch  staff       38560 19 Sep 14:57 Downloads
drwx------+   11 birch  staff         352 24 Aug  2020 Music

~/Documents describes "custom access" for "Sharing & Permissions". Could that be significant?

Closer look at permissions, as requested by @nohillside:

ls -ldOe@ ~/Documents
drwx------@ 425 birch  staff  - 13600 25 Aug 09:22 /Users/birch/Documents
    com.apple.macl     72 
 0: group:everyone deny delete

ls -ldOe@ ~/Downloads
drwx------@ 1205 birch  staff  - 38560 19 Sep 17:35 /Users/birch/Downloads
    com.apple.macl     72 
 0: group:everyone deny delete

I do not sync ~/Documents with iCloud, nor is it used for Dropbox or OneDrive:

I am using macOS 11.5.2 Big Sur on a MacBook Pro (Retina, 15-inch, Mid 2014). I think this problem started with Big Sur.

I am using APFS filesystem. ~/Documents contains 115GB of content, across 421 items.

This is an Administrator account (and I presume is also the system owner).

The problem still reproduces in Safe mode.

Any ideas? Being unable to navigate to folders makes macOS terribly broken for me.

=====

UPDATE: I tried a lift-and-shift.
tl;dr: didn't fix ~/Documents. but moved my files into a directory which isn't cursed.

The plan:

  1. Copy my documents into a new folder
  2. Confirm that the new folder works fine
  3. Delete ~/Documents
  4. Rename my new folder to be ~/Documents

I did the copied all of my documents into a new folder, ~/Docs:

rsync -a ~/Documents/ ~/Docs

Sadly rsync doesn't make use of APFS cloning, so took a bit of time and space.

This new ~/Docs folder was not afflicted by the navigation bug.

Before going as far as to delete ~/Documents, I decided to do one more check: if I delete all the files inside it, does it recover?
The answer was no (admittedly I deleted via Finder Select All, so may have missed something).

Next step was to delete ~/Documents (don't do this):

sudo rm -rf ~/Documents

This had very weird results. No error message. But the ~/Documents folder was still there (in Finder and in the Terminal -- confirmed by ls and stat).

If you attempted to navigate to this "deleted" ~/Documents folder (for example with Cmd Shift O): the breadcrumb in the Finder window would just say Documents (with no parent folders).

This scuppered my plan to "rename ~/Docs to become my new ~/Documents folder". I was likewise disallowed from executing (for example) mkdir ~/Documents, on the grounds that such a folder "already existed".

So, lift-and-shift wasn't possible. And I didn't want to use the ghost ~/Documents whilst it was clearly displaying the wrong absolute filepath in Finder.
I needed to get back to at least having a "no more broken than usual" ~/Documents folder.

I rebooted, and my ~/Documents folder was back to "as broken as usual" (i.e. the Finder breadcrumb presented the correct absolute filepath).

I believe the reason it self-repaired is related to some iCloud sync behaviour. Users that have iCloud sync enabled for their Documents folder will find that it is empty (maybe absent?) until a few seconds after login. I do not have iCloud sync enabled, but I suspect some support here tried to enforce that "there should always be a Documents folder".
So, reboot may have been overkill: a logout/login may have sufficed.

Anyway, my ~/Documents folder is still cursed. To the extent that even deleting it and regenerating it didn't help. Any more ideas?

Alternatively, does anybody know a way to rebind Finder's Cmd + Shift + O to navigate me to my new ~/Docs folder?

9
  • I have "custom access as well", nevertheless: Can you run ls -ldOe@ ~/Documents and add the result?
    – nohillside
    Sep 19, 2021 at 15:34
  • thanks for the suggestion @nohillside. I've added the results; looks identical to the working folder ~/Downloads
    – Birchlabs
    Sep 19, 2021 at 16:38
  • does cd ~/Documents/untitled \folder work as expected in Terminal? Sep 19, 2021 at 16:59
  • @KevinGrabher yes, cd ~/Documents/untitled\ folder in Terminal works perfectly.
    – Birchlabs
    Sep 19, 2021 at 17:02
  • If you create from the Finder a new folder in ~/Documents, have you the same problem? How did you create these "untitled ..." folders?
    – user415185
    Sep 20, 2021 at 4:51

1 Answer 1

0

I use the answer from, because I can't give the command in comment mode

Can you try this command from terminal to reset user permissions :

diskutil resetUserPermissions / `id -u`
5
  • I've now done this, but it didn't fix the problem. thanks for suggestion.
    – Birchlabs
    Sep 21, 2021 at 21:22
  • Ok. Can you add the results of the command ls -ldOe@ ~/Documents/untitled folder?
    – user415185
    Sep 22, 2021 at 5:03
  • drwxr-xr-x 3 birch staff - 96 19 Sep 15:27 /Users/birch/Documents/untitled folder
    – Birchlabs
    Sep 22, 2021 at 16:23
  • If you boot in Safe Mode (push shift key at boot) have you the same problem?
    – user415185
    Sep 22, 2021 at 20:15
  • I've just tried Safe Mode -- no improvement, I'm afraid.
    – Birchlabs
    Oct 16, 2021 at 22:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .