I ran these commands as suggested in another thread:

sudo find /private/var/folders/ -name com.apple.dock.iconcache -exec rm {} \;
sudo find /private/var/folders/ -name com.apple.iconservices -exec rm -rf {} \;
sudo rm -rf /Library/Caches/com.apple.iconservices.store

After that, I am trying to change app icons by going to Get Info, selecting the icon, and pasting an image in the selection. However, instead of the icon, I get a generic file icon like below:

enter image description here

How can I revert those commands?

  • RE: "How can I revert those commands?" -- You cannot as sudo rm -rf on the target is final, it's gone for good! To change an icon, have a look at: Change icons for files or folders on Mac Sep 17, 2021 at 23:03
  • @user3439894 I have tried exactly what your linked article says but what I get is the generic icon as shown on my screenshot in my question. That generic icon is set as the app icon. The same happens with files and folders. The actual picture is not shown. Sep 18, 2021 at 10:00
  • 1. What version of macOS are you running? 2. Have you rebooted since deleing the iconcache and other files? 3. Ary you opening the image in an application to then copy it to the clipboard? What application are you copying the images in? 4. If on macOS Big Sur, you cannot use that procedure in the Apple support document on any of the preinstalled applications as they reside on a cryptographically signed read-only volume. Sep 18, 2021 at 10:07


You must log in to answer this question.

Browse other questions tagged .