0

My setup is as follows:

  • MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports) running macOS Catalina
  • Dell U2720Q monitor

Monitor is connected to MacBook Pro using CableMatters USB-C to DisplayPort Cable (www.cablematters.com)

I am running into HDCP error when playing movies on Amazon Prime Video (https://www.primevideo.com). Screenshot below:

amazon prime HDCP error

I am getting same error when I use Belkin HDMI to HDMI cable (instead of above mentioned one).

Is my system/os outdated or there is something else? Please help.

Additional info:

  • Monitor that I am using, Dell U2720Q supports HDCP (DP 1.4 - HDCP 1.4/HDCP 2.2 and HDMI 2.0 -HDCP 1.4/HDCP 2.2)

I have encountered above mentioned issue on latest versions of Google Chrome and Microsoft Edge browsers

4
  • No your Mac is not too old, to the best of my knowledge. Since you have tried two different cables that eliminates my first suggestion. Have you tried a USB-C/Thunderbolt cable just to eliminate cable issues? If you can attach it to another Mac that might narrow it down to a problem with the Mac or a problem with the monitor. Sep 16 '21 at 13:32
  • 1
    Which browser are you using? Have you tried a different browsers? Have you confirmed your HDMI adapter and cable support HDCP? Sep 16 '21 at 19:10
  • Thanks for your replies Steve and Kevin. I have added additional information. Still, I am not able to identify if cable that I am using (CableMatters USB-C to DisplayPort Cable) supports HDCP or not.
    – I-M-JM
    Sep 22 '21 at 6:18
  • Also, not sure if browser is culplirt here.
    – I-M-JM
    Sep 22 '21 at 6:20

You must log in to answer this question.

Browse other questions tagged .