4

For the life of me I cannot resolve this issue. I was given a 2013 MacBook Air and upgraded it to Big Sur using my work’s WiFi.

At home it will connect only to the 5GHz network (it will not connect to 2.4GHz it says “incorrect password” even though it’s correct). Once connected it shows the green dot and connected IP, however no webpages will load.

I’ve spent hours trying things online such as:

  1. Restarting router/modem
  2. Deleting system configuration files in the preferences library
  3. Changing network options under the network pretences for DNS
  4. Forgetting the network and re-adding it
  5. Starting in Safe Mode - problems still persist
  6. Clearing DNS cache via Terminal
  7. Adding “new” locations
  8. Making sure time/date/region settings are correct
  9. Turn off firewalls and removing anti virus software
  10. Checking router blacklist & settings

I do not know where to go from here, the laptop works on other connections as well as my phone Hotspot.

Most errors in the browser window are “DNS_PROBE_... NO INTERNET”

When I checked my DNS via Terminal, there are 7 resolvers all unreachable and at the bottom under (for scoped queries) Reachable (8.8.8.8)

I have fiddled around with so many different “fixes” online and nothing has worked.

Any advice would be highly appreciated

2 Answers 2

0

Sounds like there is no DNS Server in your Network-Settings. Preferences > choose your network (green) > go on "Advanced" > DNS and Search Domains. Which entry? Do you have a Proxy entry? A leftover from your AD in your Company?

Probably your Router is misconfigured not allowing other users to connect. This could happen with a new OS too.

Sometimes you need to delete the account of your Wi-Fi and configure it new.

1
  • 1
    It seems that the points you mention are already listed in the question.
    – nohillside
    Commented Sep 20, 2021 at 15:22
0

When I checked my DNS via Terminal, there are 7 resolvers all unreachable and at the bottom under (for scoped queries) Reachable (8.8.8.8)

This actually tells us a lot: the DNS server hosted by Google is reachable. However, this DNS entry must have been manually inserted because ISPs prefer to give you a DNS host they can do analytics on.

Try running this command from Terminal:

% host 8.8.8.8

You should get a response that looks like this:

8.8.8.8.in-addr.arpa domain name pointer dns.google.

If you get a response, you are connected to the Internet, but for some reason, you cannot resolve hosts. If you don't get a response, then there's likely a network issue.

Networking Troubleshooting

  • Start by pinging your router. If you don't know what the router address is, issue the command:

    % ipconfig getpacket <en0/1> | grep router.    ← en1=WiFi; en0=Ethernet (usually) 
    

    Then, ping the router with the command:

    % ping 192.168.1.1                             ← Example router IP; yours may differ
    

    If that works, try pinging a public IP like 142.250.64.174 for Google.

    % ping 142.250.64.174
    

    If that works there, you've confirmed that you have Intrnet access and the problem is DNS related (names won't resolve).

DNS Troubleshooting

  • Start by removing all of the manual DNS entries. Your router's DHCP server should give you the DNS server supplied by your ISP.
  • Release and renew your DHCP lease from your router. Go into Settings → Network → [Select Adapter] → Advanced → TCP/IP then click Renew DHCP Lease
  • Release and renew the lease from the ISP. Thes specific steps will differ depending on the router manufacturer, but the steps are essentially the same:
    1. log into the router admin page
    2. go to the WAN/Internet configuration
    3. select "Release/Renew" DHCP lease.
    4. Repeat the steps to renew the lease on your Mac from the 2nd bullet point.

These troubleshooting steps should either get your issue resolved or at least give you enough feeback to point you in the right direction.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .