2

I have just updated to 4.2, and the space for my music is still taken according to iTunes, and the device "About" screen says I have 723 songs, but I cannot see it in the iPod app. I assume that another sync is required to activate the content again or something to that effect?

iTunes can see the content on my phone and even allow me to play it. I will attach some images to illustrate the issue. My photo library was updated and seems to work. I have also tried closing all apps, which did not help.

iTunes showing list of songs

  • I had the same problem as did lots of people based on some quick Google searches this morning. Sounds like a tester at apple will be out of a job today. – JohnFx Nov 23 '10 at 13:38
0

To add to your own answer, you will have to re-sync with your library or reset some contents (via the correct iTunes).

1

I am speculating, that this is what happened: I did the update on another computer (not the one my music is synced to), which invalidated the copy protection of my music library, so when I plugged my phone back into the machine where my music library is stored it did the deed for me. That is what seems to have happened anyway.

1

While Martin's answer is correct to bring back the songs, but here the songs are not lost/ disappeared from iPhone. There is a way to fix this.

After upgrading to 4.2.1, the songs are still there, but by somehow the songs are not shown in iPod.app. All I did is plug-in the headphones and click the middle button to play the songs. And it did worked.

No need to re-sync the songs.

0

found the answer with the second suggestion here.

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Apr 6 '17 at 22:07
-1

Re-start touch (Hold home and off/on buttons) and sync again with iTunes, bingo!

  • tried that . .didn't help . .still says "No content" – leora Dec 25 '10 at 0:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .