I've had the annoying issue of not being able to pair with bluetooth devices on my laptop unless I restart it. This happens for multiple headsets which all pair without issue on other devices and on this laptop as well after the restart.

Some of the pairing behavior includes:

  • I click the device to pair. The macOS ui shows the device as paired and the device says "bluetooth connected". The headset doesn't show as an audio output device and after a few seconds the bluetooth disconnects
  • With another headset, I click to pair the device and it either loads for a while before failing or connects and immediately disconnects.

I've tried

  • all the reset options under the bluetooth menu shown by pressing option + shift
  • stopping the audio daemon with sudo killall coreaudiod
  • clearing the nvram
  • sudo kextunload /System/Library/Extensions/AppleHDA.kext + sudo kextload /System/Library/Extensions/AppleHDA.kext

I'm not sure what to do to troubleshoot this issue. I've tried looking at the logs in console when trying to connect a headset and it fails, but I'm not sure what exactly to look for there.

I'm using a 2019 Macbook Pro on macOS Big Sur 11.5.2.

  • 1
    Same issue on MacBook Air (Retina, 13-inch, 2020) running macOS Big Sur 11.5.2.
    – Volsk
    Sep 7, 2021 at 19:04
  • @Volsk if you have android file transfer installed try quitting that process when this happens. Worked for me :)
    – mowwwalker
    Sep 9, 2021 at 21:35
  • Actually this happened again with Android File Transfer not running
    – mowwwalker
    Sep 14, 2021 at 19:52

1 Answer 1


This happened again and seems to have been fixed by stopping the "Android file transfer" process using Activity Monitor as suggested here: https://discussions.apple.com/thread/8631469

edit: the issues connecting happened again but stopping Android File Transfer didn't fix it. Leaving this answer up in case it works for anyone

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .