0

"at" jobs keeps popping an alert asking if I want to give terminal extra permissions.

enter image description here

I give it permissions, but on the next "at" invocation it repeats the pestering,

how would I make it cease and desist?

3
  • Do you know what is asking for this permission? (If possible please post a screen shot).
    – sfxedit
    Sep 7 at 8:44
  • I get shafted by settings judging from the icon. Judging from the message it's core macOS itself. Sep 7 at 9:44
  • Does Terminal have Full Disk Access allowed in System Preferences?
    – nohillside
    Sep 7 at 12:06
1

You have to provide "Full Disk Access" to Terminal to prevent this kind of alert:

  1. Open System Preferences from Apple menu.
  2. In System Preferences click on Security & Privacy.
  3. In Security & Privacy, click on the Privacy tab.
  4. Select Full Disk Access from the left sidebar.
  5. Click on the Lock icon to make changes, and provide it an administrator user / password.
  6. Click the + button (below the list of apps).
  7. Add Terminal App (it can be found in Applications > Utilities).
  8. Make sure that the checkbox next to Terminal is ticked.

Screenshot of macOS System Preferences - Security & Privacy - Privacy dialog window

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .